Closed Bug 209070 Opened 21 years ago Closed 19 years ago

about:config is broken, shows columns but no data

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Camino1.0

People

(Reporter: chris, Assigned: sfraser_bugs)

References

()

Details

(Keywords: fixed1.8)

not much to add really, about:config isn't very useful as it only shows the
column headers and not any preference info.

I'd be perfectly happy with it either working or removed... but right now its
kindof in the middle and looks like a bug.

Camino 2003061104
ther's another bug on this, but i can't find it now. it's cuz we don't support
xul. we should clean this up.
Assignee: saari → pinkerton
Target Milestone: --- → Camino1.0
You are probably refering to Bug 199203, thought it's about plugins.

Note that all the about: stuff is broken.
about:buildconfig and about:mozilla work.

it would be nice to get about:config working.
This happend to me on Firefox 8.0 under Linux.   about:config normally works for
me but recently it simply displayed the column headings and search box with no
data.  The search string text was empty (so I wasn't looking at a reduced
subset) and the show all button was grayed out.   When I restarted the browser
it fixed it.
problem #1: you aren't packaging layout_xul_tree.xpt.
fixing this requires a change to Camino.xcode/project.pbxproj

problem #2: something to do w/ stringbundles - i'll figure this out later.

if someone would fix #1, i'd appreciate it. I'm having a rough time w/ xcode.
(and i have my own diffs to the xcode project which people won't like...)
duplicate of Bug 199203?
suishouen@mac.com: that was already suggested, but it's not strictly the same,
and fixing one is not guaranteed to fix the other.
Wevah has prepared a pref-pane (currently only as an additional one that you
have to add into your installation) that basically duplicates the same
functionality as about:config, but as a proper pref pane. This is much more mac
like that using about:config (and has the advantage of working :-).

The downside of it is that (without introducing a rather bizarre pref to enable
an additional pref panel) it would be readily visible to all users, whereas
having to type about:config raises the bar somewhat, and makes it clearer that
its more serious than just selecting a pref pane.

I think we should have a debate about which approach we want to use for 1.0.
Actually, the pref pane is Geoff's!

;)
Is Geoff's prefPane available anywhere in the interim?  Will it be made
available for download as a separate (not part of Camino) item for those that
desire it in 0.9 (much like eccoana's CamiOptions and CamiFlash)?

Now that we have drop-in prefPanes in the profile, the about:config prefPane
should be easy to install yet not need to be included in Camino, which should
alleviate most of Bruce's concerns in comment 8.
Just for reference.
Hiroto Sakai releases "Camino AboutConfig.prefPane 1.0.1".
http://www.fan.gr.jp/~sakai/moz.php
Download for Camino AboutConfig.prefPane 1.0.1
http://www.fan.gr.jp/~sakai/files/aboutconfig-1.0.1.dmg
I'll start the debate mentioned in comment 8 by Bruce.

I don't think we should expose about:config as most Moz browser do. I think we
should provide for download a 3rd party pref panel that does about:config
similar (if not!) Geoff's Kitchen Sink. To stay user focused, we shouldn't
provide the pref pane by default, but rather as a separate download from our
(upcoming) caminoextras website.
I agree with Samuel, and that we should disable about:config.

The best way to do it, would be to display nothing, but just open the standard
preferences window.
Unfortunately about:config is registered down in necko:
http://lxr.mozilla.org/mozilla/source/netwerk/build/nsNetModule.cpp#993
even though the UI had dependencies on a whole bunch of non-embedding stuff. Sigh.
It turns out that we just need to copy over layout_xul_tree.xpt to fix this.
Assignee: pinkerton → sfraser_bugs
Fixed on trunk and branch.
Status: NEW → RESOLVED
Closed: 19 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.