javascript pop-up window not resizeable & no scroll bars

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: geo. anderson, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

I have seen this one once in a while, never reported it as I assumed others
would have done so.  The general problem (NT4.0/sp6a) is that clicking a link
that uses javascript to make a pop-up window results in the pop-up being oddly
shaped (tall and narrow) and neither resizeable nor with scroll bars.  So it is
impossible to read what is in most of the window.  These are usually
send-a-message-t0-us type windows.

You will have to register as a user at the forum link above, but then go to
someone's message and attempt to send an email to the user.  Or send a message
to user durequip -- that's me, so it is harmless.  You should be able to
duplicate the problem.

Reproducible: Always

Steps to Reproduce:
1. go to forum
2. register a username
3. attempt to email or foward a topic to another member, like "durequip"

Actual Results:  
see above

Expected Results:  
resizeable & with scroll bars as needed
I see the same behavior at http://www.theagitator.com. No registration is
required. Click on one of the "comments" links (which uses javascript to open a
new popup window). The popup window has no scrollbars and is not resizable. In
IE6, the popup window has scrollbars and is resizable. I am using a
post-Firebird 0.7 nightly build: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.5) Gecko/20031007 Firebird/0.7

Comment 2

14 years ago
Assuming the first page is essentially the same as the one referenced by Chris,
the problem is invalid syntax in their call to window.open. They specify the
features of the window (scrollbar, resizable, etc.) in a list separated by
spaces where JavaScript requires them to be separated by commas. I guess IE is
more tolerant of this. I wouldn't be surprised if there is a duplicate bug on
this, but I couldn't find it after searching for a while.

Comment 3

14 years ago
This is invalid in my opinion, they're using illegal syntax. If someone thinks
Mozilla should accept this, perhaps a new enhancement bug could be filed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.