Password Manager fails to remember password for Microsoft Outlook Web Access

RESOLVED DUPLICATE of bug 220022

Status

SeaMonkey
Passwords & Permissions
RESOLVED DUPLICATE of bug 220022
15 years ago
12 years ago

People

(Reporter: Dan Kegel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

I use a webmail interface daily.  Since switching to 1.4beta,
I have to type in my username and password nearly every time.
I can't figure out what makes Password Manager fail to fill in the
username and password.  It's still listed under "Manage Stored Passwords".
Mysterious!  I'll try clearing them out of "Manage Stored Passwords"
and see if it magically fixes it...

Reproducible: Sometimes

Steps to Reproduce:
1. Log in to mail.ixiacom.com several times every day
2. Eventually mozilla will not retrieve your password from Password Manager and
you'll have to type it in again, even though it's still listed in "Manage Stored
Passwords"


Actual Results:  
Had to type in username and password again to log in

Expected Results:  
Password Manager would fill in username and password
Have you tried to delete the entry in the PWD-Manager and store it again ?
(Reporter)

Comment 2

15 years ago
Yes.  I deleted the username/password from "Manage Stored Passwords",
but that didn't help.

More details: when the problem happens, I can often just click "cancel"
on the http authentication prompt, reload, and the page will show up fine!  
I'm starting to think the password is there just fine in the
manager, but for some reason the lookup fails sometimes.
(Reporter)

Comment 3

15 years ago
OK, a few more details.  Happens even with 20030624 (mozilla 1.4 rc3?).

When it happens, I can click 'cancel' on the http auth prompt, then reload,
and get the page -- but only once.  After that, the password is more thoroughly
forgotten.

It's almost as if the password manager is now obeying some timeout.
"View info" on the page and frames doesn't show any HTML expiration,
though.  It's a bit of a mystery.

I've made the summary more specific, since Microsoft Outlook Web Access seems to
be the only web application affected for me.
Summary: Password Manager fails to remember password → Password Manager fails to remember password for Microsoft Outlook Web Access

Comment 4

15 years ago
The problem is not only with OWA. I have the same issue with SAP Business
Connector (webMethods Integration Server). The problem seems to be with the
authentication against the web server itself. User names and passwords in web
pages are remembered correctly. I verified this behaviour with a clean install
of build 2003062904 on W2k.
Ok, this is gettting fuzzy.
Password manager handles filling in your password in a dialog, or in a webform,
so you don't have to type it in the next time you start your browser.
It has nothing to do with forgetting authentification when going from one page
to the other.

All this problems sounds like that during one seesion, the auth details are
forgotten. So this is maybe more a http problem. Darin, any ideas?

Comment 6

15 years ago
what we need is a HTTP log...

dan: can you please follow the steps outlined here:

  http://www.mozilla.org/projects/netlib/http/http-debugging.html

to generate a HTTP log for this bug?  thanks!

Comment 7

13 years ago
(In reply to comment #6)
> what we need is a HTTP log...
> 
> dan: can you please follow the steps outlined here:
> 
>   http://www.mozilla.org/projects/netlib/http/http-debugging.html
> 
> to generate a HTTP log for this bug?  thanks!

I have been having the same problem, starting a few weeks ago.

I followed these instructions.  I'm putting the log on
http://finzi.psych.upenn.edu/~baron/bug209180.txt

The sequence is as follows:

1. Mozilla connects to my home page on startup: http://www.sas.upenn.edu/~baron

2. I connect to my wife's webmail at http://webmail.wcupa.edu
(So far, you can do this.)

3. I click on "Employees login here" and log in with the password manager.

4. I log out and use the "Go" menu to go back to my home page.

5. Then I go to the webmail site again.  At first I get the password
dialog, but I click "OK" and get taken to the page you can see at
webmail.wcupa.edu.  The password box is now empty.  The password has
just disappeared from 25955227.s at this point.  (I have checked this
by examining 25955227.s repeatedly and restoring it from backup.  The
password disappeares from it at the second attempt to log in.)

6. I again click "Employees login here" and the password is still gone.

Note:  I've reported this as part of some other bug, but I can't find it.
When I search bugzilla for my name or email, nothing relevant comes up.
But I really think the present bug is the right one.
Product: Browser → Seamonkey

Comment 8

13 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

12 years ago
I have also found that during the course of using Firefox 1.5.0.3 for several hours, I get prompted to re-enter already-saved usernames and passwords.  When I check the password manager, it is completely empty!  If I exit Firefox and restart, the password manager now shows all of my saved info again.

In my case, this is not limited to OWA.  This can happen on any webpage that requires my saved usernames and passwords.
Assignee: dveditz → nobody
Sounds like yet another duplicate of bug 220022

*** This bug has been marked as a duplicate of 220022 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.