Bus Error (mozilla crashes) due to Sun's Jave Runtime Environment

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
8 years ago

People

(Reporter: jared.jones, Assigned: joshua.xia)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4b) Gecko/20030606
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4b) Gecko/20030606

I am running mozilla-1.4b on SPARC/Solaris-8 with no root access, Gnome-2.2 and
everything is installed under my home directory.  Mozilla works fine until I
link Sun's j2re1.4.1_03 (or version 01) plugin/sparc/ns600/libjavaplugin_oji.so
to my ~/.mozilla/plugins directory.  Once I make this link, mozilla crashes with
"Bus Error" and the only way I can get it running again is by removing the link.

Maybe the problem is I use gtk-2, freetype/fontconfig (anti-aliased) fonts, and
gcc-3.2.1.  Sun's JRE is probably compiled with gtk-1.2, and Forte or some
different gcc version.

But, how can I get Java using my build of mozilla?  If I cannot use Sun's JRE,
where can I go?  Thanks.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
-> Oji
Assignee: peterlubczynski → joshua.xia
Component: Plug-ins → OJI
QA Contact: bmartin → dsirnapalli

Comment 2

15 years ago
you're using GCC 3.2, try again with Sun's JRE 1.4.2 beta using the ns610gcc32
(at least, it works on Linux, don't know about Solaris).

Comment 3

15 years ago
Can you confirm the version of GNOME 2 that you are using.
GNOME 2.0 is the version that Sun have packaged and is available for download on
their site. If you are using GNOME 2.2 did you compile it using gcc 3.2.x.
If so your non-forte compiled GTK2.x libraries are could be causing the
unexpected Java behaviour.
You generally get Bus Error's with Mozilla on the Sun when you're missing
libraries in your PATH and/or LD_LIBRARY_PATH variables.
Can you do a 'ldd mozilla-bin' in the mozilla directory and attach the output.
(Reporter)

Comment 4

15 years ago
  I downloaded j2re1.4.2-sparc-solaris and the v9 stuff.  There is no
sparc/ns610gcc plugin, there is only sparc/ns610.  This time when I symbolically
link the plugin library in my ~/.mozilla/plugins directory, I get this different
error:

 INTERNAL ERROR on Browser End: No manager for initializing factory?

System error?:: Error 0


  I am using Gnome-2.2 compiled from source because I do not have root access,
so everything is in my home directory, compiled with gcc-3.2.1.  Below is my
mozilla-bin.  I agree my gtk-2 gcc-compiled libraries are probably the issue,
but is there a JRE out there for sparc/solaris compiled with gcc-3.2.x?

~/usr/mozilla-1.4/lib/mozilla-1.4b/ > ldd mozilla-bin 
	libmozjs.so =>	 (file not found)
	libplds4.so =>	 (file not found)
	libplc4.so =>	 (file not found)
	libnspr4.so =>	 (file not found)
	libdl.so.1 =>	 /usr/lib/libdl.so.1
	librt.so.1 =>	 /usr/lib/librt.so.1
	libgtk-x11-2.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libgtk-x11-2.0.so.0
	libgdk-x11-2.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libgdk-x11-2.0.so.0
	libatk-1.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libatk-1.0.so.0
	libgdk_pixbuf-2.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libgdk_pixbuf-2.0.so.0
	libpangoxft-1.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libpangoxft-1.0.so.0
	libpangox-1.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libpangox-1.0.so.0
	libpango-1.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libpango-1.0.so.0
	libgobject-2.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libgobject-2.0.so.0
	libgmodule-2.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libgmodule-2.0.so.0
	libglib-2.0.so.0 =>	 /home/jjones1/usr/gnome-2.2/lib/libglib-2.0.so.0
	libintl.so.2 =>	 /home/jjones1/usr/lib/libintl.so.2
	libiconv.so.2 =>	 /home/jjones1/usr/lib/libiconv.so.2
	libsocket.so.1 =>	 /usr/lib/libsocket.so.1
	libm.so.1 =>	 /usr/lib/libm.so.1
	libstdc++.so.5 =>	 /home/jjones1/usr/lib/libstdc++.so.5
	libgcc_s.so.1 =>	 /home/jjones1/usr/lib/libgcc_s.so.1
	libpthread.so.1 =>	 /usr/lib/libpthread.so.1
	libc.so.1 =>	 /usr/lib/libc.so.1
	libaio.so.1 =>	 /usr/lib/libaio.so.1
	libXext.so.0 =>	 /usr/openwin/lib/libXext.so.0
	libXft.so.2 =>	 /home/jjones1/usr/lib/libXft.so.2
	libXrender.so.1.1 =>	 /home/jjones1/usr/lib/libXrender.so.1.1
	libfontconfig.so.1 =>	 /home/jjones1/usr/lib/libfontconfig.so.1
	libX11.so.4 =>	 /usr/openwin/lib/libX11.so.4
	libfreetype.so.6 =>	 /home/jjones1/usr/lib/libfreetype.so.6
	libnsl.so.1 =>	 /usr/lib/libnsl.so.1
	libdga.so.1 =>	 /usr/openwin/lib/libdga.so.1
	libexpat.so.0 =>	 /home/jjones1/usr/lib/libexpat.so.0
	libmp.so.2 =>	 /usr/lib/libmp.so.2
	libthread.so.1 =>	 /usr/lib/libthread.so.1
	/usr/platform/SUNW,Sun-Blade-100/lib/libc_psr.so.1
OS: SunOS → Solaris

Comment 5

15 years ago
Sun's JRE is compiled using Forte (but no gtk), you should also download a
Forte-build mozilla which will be contributed by Sun and other individuals at
every mozilla official release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.