the background color of a groupbox caption in a tab is wrong (classic theam)

RESOLVED DUPLICATE of bug 236107

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 236107
15 years ago
10 years ago

People

(Reporter: Mark Kaplun, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

615 bytes, application/vnd.mozilla.xul+xml
Details
9.89 KB, image/png
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

The classic theam is using a constant color (dialog color) as the background
color of a groupbox caption. This works realy fine when the groupbox is located
in a dialog window, but when it is placed inside a tab which have a different
background color, the gray background color is wrong.

Selecting a different color as the background does not help, since the tab uses
some kind of white gradient (hope I use the right term) as background, which
means that it is not the same white at every place of the window.

Removing the background color definition from the CSS, makes the groupbox border
to be showen behind the caption text.

Reproducible: Always

Steps to Reproduce:
1. Open the attached xul file
2.
3.

Actual Results:  
The groupbox caption has a gray background.

Expected Results:  
No background should be shown for the caption
(Reporter)

Comment 1

15 years ago
Created attachment 125533 [details]
Test xul file
(Reporter)

Comment 2

15 years ago
*** Bug 209229 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
maybe related to bug 185435
(Reporter)

Comment 4

15 years ago
Don't think so. IMHO the problem here is that the line of the groupbox is 
always drawen behind the caption, therefor you have to apply some kind of 
background color to the caption in order to hide the relevent portion of the 
line. 

IMHO the best solution is to draw calculate the amount of space required for 
the caption and draw the line only outside of this space, and then the 
backgound color definition for the caption can be removed.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 6

13 years ago
Created attachment 198803 [details]
Shows the caption bug

This bug is still unfixed in FF beta 2 (Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1).

Comment 7

13 years ago
this is dup of bug 236107

*** This bug has been marked as a duplicate of 236107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.