Closed Bug 209290 Opened 17 years ago Closed 9 years ago

DHTML sites - dataloss bug caused by new groupmark behaviour (replace instead of append)

Categories

(SeaMonkey :: Tabbed Browser, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: pascalc, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: dataloss, regression)

Build 2003060908 WinXP

1 go to http://demo.bitfluxeditor.org/ (or any page using DHTML to alter
content, change elements, calculate data...)
2 edit the page
3 click on a groupmark
4 click on back 

expected result : we should go back to the page at the state it was before
clicking on the groupmark
actual result : work did on the page is lost, the page is reset. Dataloss.
Depends on: 203960
*** Bug 209292 has been marked as a duplicate of this bug. ***
This should be marked as duplicate of bug 203960.
no, this is a consequency of 203960 not a duplicate. When the "append" behaviour
option will be restablised, people using the "replace" behaviour will still
suffer from this bug.
Note bug 288462.
Blocks: 288462
Depends on: 386782
The editableness and data loss was fixed by checkin for either bug 430624 or bug 386782. I don't see a caret in the editable area though.
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser
Bookmark groups are gone on SeaMonkey trunk (2.1b2pre) Also based on Comment 5 I am closing as WFM
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.