If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Store image dimensions in cache

RESOLVED DUPLICATE of bug 47660

Status

()

Core
Layout
P3
minor
RESOLVED DUPLICATE of bug 47660
18 years ago
17 years ago

People

(Reporter: Scott Furman, Assigned: pnunn)

Tracking

({perf})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

Attachments

(1 attachment)

Description

18 years ago
Mass move of all bugs without target milestones to M13.
(Reporter)

Updated

18 years ago
Assignee: fur → troy
(Reporter)

Comment 1

18 years ago
Troy, you may not be the right person for this, but please see that this bug
finds a good home...

The network data cache allows any number of "annotations" to be placed on a URL.
These annotations have a lifetime that is potentially much longer than that of
the associated cached content, since the URL metadata is not erased as long as
the cache deems a URL as "important", i.e. likely to be loaded again in the
future.

An annotation could be used to persistently store a hint for the dimensions of
an image, hence avoiding a reflow in cases where an image's data is not in the
image cache or the network cache, but it has been loaded in the past.
(Reporter)

Comment 2

18 years ago
Created attachment 3332 [details]
code to store image dimensions in cache (untested)
This sounds like a good idea. So long as we fall back on the real dimensions
should they turn out to have changed... :-)

Updated

18 years ago
Keywords: perf
Summary: [Perf] Store image dimensions in cache → Store image dimensions in cache

Updated

18 years ago
Target Milestone: M15 → M17

Updated

18 years ago
Assignee: troy → dcone
Status: ASSIGNED → NEW
reassigning to dcone. Triaging Troy's bug list.

Comment 5

18 years ago
Pam.. is this your area?
Assignee: dcone → pnunn
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 6

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.  If you can give PDT info on 
 big win, low risk for PR2, let us know. 
Whiteboard: [nsbeta2-]
(Assignee)

Comment 7

17 years ago
Neeti:
Does this sound like it would help performance?
The recommendation was fur's.
-p
(Assignee)

Updated

17 years ago
Target Milestone: M17 → Future
Adding nsbeta2 keyword to bugs with nsbeta2 triage value in status field so the 
queries don't get screwed up
Keywords: nsbeta2
(Assignee)

Comment 9

17 years ago
dupe of 47660. (#47660 has more info on issue.).
-p

*** This bug has been marked as a duplicate of 47660 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.