Hebrew Diacritics cause justifed text to be inappropriately shifted

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: eyalroz, Assigned: mkaply)

Tracking

Trunk
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030605
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030605

In

http://www.earendil.ath.cx/index.shtml.he

observe the second H2 element on the page. One sees not only the manifestation
of bug 60546 (http://bugzilla.mozilla.org/show_bug.cgi?id=60546), but also a
shifting to the right of the header text, which causes some of it to go
off-window. Note also that it is not possible to scroll right and view the text.
Regardless of whether the diacritics appear in their correct position, no such
shift should occur.


Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
I can't reproduce this using the Mozilla Linux trunk 2003-06-13 build. Perhaps
you could attach a screenshot. I am assuming that the line in question is one
that says "Mi hu Earandil?" Is that right? For the build i mention, the line is
aligned just like the others.
Can you also attach a reduced testcase? The URL gives me a page saying "This
page has been temporarily blocked".

I'm not sure that this is a separate bug from bug 60546, I think it's just a
knock on effect from the incorrect character positioning metrics for the diacritics.

Comment 4

16 years ago
What is odd is that with my Linux installation, the diacritics appear after the
character rather than on the character, as described in 60546, but at the same
time i don't see the misalignment described in this bug. If you look at the
screenshots for some of the bugs duped to 60546 you see the bad diacritics but
no misalignment with respect to the margin, while in others you see the
misalignment, as well.

(Reporter)

Comment 5

16 years ago
Posted file Reduced Testcase
Note that if the 'align: justify' is removed, the text is rendered properly on
my box, including no manifestation of bug 60546
Attachment #125731 - Attachment is obsolete: true
(Reporter)

Comment 6

16 years ago
(Reporter)

Comment 7

16 years ago
Comment on attachment 125821 [details]
Screenshot of reduced testcase

New screenshot done with build 2003-06-17-04 .

Comment 8

16 years ago
I tried to view your testcase using three different encodings, but the
diacritics all came out as question marks. I'm attaching a testcase which both
specifies the encoding (so everyone can view it) and has divs with and without
"text-align: justify" (so that the difference between them can be seen).

Comment 9

16 years ago
confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a)
Gecko/20030721 Mozilla Firebird/0.6
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

16 years ago
Also, in the attached testcase, the first character falls of the page for me.
Attaching a screen shot.
(I am running winXP)
(Reporter)

Comment 12

15 years ago
Changing bug summary to better suit the testcase
Summary: Hebrew Diacritics cause right-aligned text to be shifted off-window → Hebrew Diacritics causes justifed text to be inappropriately shifted
(Reporter)

Comment 13

15 years ago
Changing bug summary to better suit the testcase
Summary: Hebrew Diacritics causes justifed text to be inappropriately shifted → Hebrew Diacritics cause justifed text to be inappropriately shifted

Updated

15 years ago
Blocks: 240501
For the record, this is what the testcase looks like on a recent trunk (Cairo-enabled) WinXP build. Both the justified and unjustified lines are now equally screwed up :-(

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061102 Minefield/3.0a1
(In reply to comment #14)
> For the record, this is what the testcase looks like on a recent trunk
> (Cairo-enabled) WinXP build. Both the justified and unjustified lines are now
> equally screwed up :-(

I suggest opening a new bug in the GFX:Thebes component.
Attachment #125819 - Attachment mime type: text/html → text/html; charset=windows-1255
The testcases are all now working in trunk builds, so this was fixed by bug 367177.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

11 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.