Scrollbars cause unecessary reflows

VERIFIED DUPLICATE of bug 72540

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 72540
15 years ago
15 years ago

People

(Reporter: Brian 'netdragon' Bober, Assigned: jag (Peter Annema))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
If you are viewing a document with no scrollbar, and then open one with a
scrollbar, it causes a reflow of the document that makes the document flicker,
and whatnot. On the other hand, Internet Explorer shows a disabled scrollbar. I
think doing it that way would be more appropriate.

Comment 1

15 years ago
I never noticed any flicker. But permanent scrollbar(s) would be extremely
annoying for me as a user and would also conflict with explicit web-design in
many cases. So to the extent there's a reflow, I wouldn't call it unecessary.
This is basically a duplcate however: Bug 179692.
(Reporter)

Comment 2

15 years ago
I sifted through a few comments and it doesn't appear as a duplicate. This bug
is about having the vertical scrollbars always visible like in IE 6, and
disabled but still visible if scrolling is not possible (i.e. a short page like
google.com)

*** This bug has been marked as a duplicate of 72540 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
v
Status: RESOLVED → VERIFIED

Comment 5

15 years ago
rkaa: bug 179692 is about windows opened by scripts, and says scrollbars=no
should be ignored when the content is long enough to require scrollbars.  It is
not the same as this bug.
You need to log in before you can comment on or make changes to this bug.