Closed Bug 20971 Opened 21 years ago Closed 20 years ago

xpi files unexpectedly removed after installation

Categories

(SeaMonkey :: Installer, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jimmykenlee, Assigned: dveditz)

Details

Build: 1999-12-06-08-M12(MAC), 1999-12-06-09-M12(WIN)

1. For Mac, from
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/1999-12-06-08-M12/MozMacI
nstaller-M12.sea.bin, download.
2. Notice that the xpi files are present.
3. Install Seamonkey.

RESULT:
The xpi files are no longer present from the install directory.  Only
config.ini, License, and Mozilla Installer remain.

EXPECTED RESULT:
xpi files remain from installer folder after successful installation.
Is this a Mac only problem? If so please mark [PP] and I'll reassign to Samir.
Appears cross-platform: Sean ran the Win32 installer and found that the .xpis
were being deleted there too.
Status: NEW → ASSIGNED
Target Milestone: M13
Blocks: 21564
Assignee: ssu → dveditz
Status: ASSIGNED → NEW
Didn't we fix this one? I guess we still need to move the delete out of
nsSoftwareUpdateRun and into the install manager.
Yes, this is fixed.
Target Milestone: M13 → M14
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Target Milestone: M14 → M13
I'm calling this fixed, I'll open a new bug on the low-level clean up.
build 2000012812
Status: RESOLVED → VERIFIED
No longer blocks: 21564
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.