show username@hostname in new email notification tooltip

VERIFIED DUPLICATE of bug 133960

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED DUPLICATE of bug 133960
15 years ago
10 years ago

People

(Reporter: Fernando Cassia, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02

I have half a dozen email addresses (and I'm think I'm not alone), and all
my emails have the same username: fcassia. So I'm fcassia@netscape.net, 
fcassia@myrealbox.com, and so on.

The "new email notification tooltip" pops up and says:
"fcassia has 1 new email".

The question is obvious, WHICH fcassia email account has new email?.

It should say:
"fcassia@netscape.net has 1 new email"
or
"fcassia@myrealbox.com
has new email"

To be safe for "someone@extremellylongdomainname.com"
not fitting the tooltip space, perhaps it could be cut at a max lenght so it says:

---------------------------
you@extremellylong(...)
has new email.
---------------------------



Reproducible: Always

Steps to Reproduce:
1. Create two or three email accounts with the same username, but different domains.
2. Send email to account #2
3. Watch for the new-email notification tooltip to display saying "username has
1 new email".
4. Try to figure out (without opening up the email client) what account the
message refers to. :)

Actual Results:  
"username" has 1 new email.

Expected Results:  
"username@host" has 1 new email.

Comment 1

15 years ago
Fernando Cassia, this is not an exact duplicate of what you want, but see bug 
133960 -- if what is discussed there is close enough, please mark this bug as a 
duplicate of that.
Severity: normal → enhancement

Comment 2

15 years ago
Bug 133960 will use a smaller notification string - and it won't be the
email-address if you change the account name (email address is the default
account name).

Because of bug 133960 comment 16, I'm duping this againt bug 133960 for the
moment - reopen if you don't agree.

*** This bug has been marked as a duplicate of 133960 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.