Last Comment Bug 209836 - [midas] designMode still active after clicking Back
: [midas] designMode still active after clicking Back
Status: RESOLVED DUPLICATE of bug 198155
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Joe Francis
: sairuh (rarely reading bugmail)
: Makoto Kato [:m_kato]
Mentors:
http://devedge.netscape.com/viewsourc...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-18 13:21 PDT by Mats Palmgren (:mats)
Modified: 2004-07-28 19:58 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mats Palmgren (:mats) 2003-06-18 13:21:08 PDT
[midas] designMode still active after clicking Back.

REPEAT BY
1. go to URL
2. click the link "First example - View Example"
3. edit some text - it works
4. click Back
5. now you can edit the original page too!

ACTUAL RESULTS
The document (URL) is editable.

EXPECTED RESULT
Going from an editable document to an non-editable document should
turn off designMode.

PLATFORM & VERSIONS TESTED
Bug occurs in Mozilla nightly trunk build 2003-06-12-22 on Linux

ADDITIONAL INFORMATION
Shift-reload on the original page did not help either - I had to close the tab
and then revisit the page in a new tab to get out of edit mode.
Also, visiting other pages when in "edit-mode" made them all editable.
Comment 1 Bob Clary [:bc:] 2003-07-01 16:54:11 PDT
happens on win2k as well and on 1.4 branch.
Comment 2 osavill 2004-02-26 05:01:36 PST
From the above URL:
 Problem

    Once document.designMode has been set for the document object in a window,
all documents in that window for that domain will remain editable.
Solution

    Edit the document in a separate window or contained in an IFRAME.

Not a good solution! Any way it still happens in build 2004021808. But it is not
just pressing back that does it, the browser appears to be stuck in edit mode.
Comment 3 Asa Dotzler [:asa] 2004-07-28 19:14:18 PDT

*** This bug has been marked as a duplicate of 198155 ***

Note You need to log in before you can comment on or make changes to this bug.