bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

search messages does not complete



MailNews: Message Display
15 years ago
10 years ago


(Reporter: Vincent DiCarlo, Unassigned)


Windows XP

Firefox Tracking Flags

(Not tracked)




15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612

When I try to search my local folders, including subfolders, which contain a lot
(407 megabytes) of data, the search stops somewhere in the middle while the
status line of the search dialog displays a message saying "Building summary
file for [subfolder name]". When this happens, if I look in the folder, there is
nothing visible in it. If I close email and restart, the folder still appears
empty. If I close Mozilla entirely, including the quickstart, everything resets
and the folder is displayed properly, but repeating the same search produces a
hangup at the same place. If I delete the folder, and search again, the problem
occurs on another folder. The problem occurs regardless of whether the search is
of the subject line or the body, but does not occur for smaller searches that
encompass just the subfolder on which the search will hang if a more
comprehensive search is done. 

Reproducible: Always

Steps to Reproduce:
1. Do a search of subject line or body on Local Folders including subfolders.
2. Wait for the search to hang up with a message saying ""Building summary file
for [subfolder name]"
Actual Results:  
The search stops somewhere in the middle while the status line of the search
dialog displays a message saying "Building summary file for [subfolder name]".

Expected Results:  
Completed the search.

Comment 1

15 years ago
*** Bug 209851 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey


13 years ago
Assignee: sspitzer → mail
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Last Resolved: 13 years ago
Resolution: --- → EXPIRED


10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.