Mozilla calendar almost crashes when disabling/enabling a calendar

RESOLVED DUPLICATE of bug 198142

Status

Calendar
General
RESOLVED DUPLICATE of bug 198142
15 years ago
12 years ago

People

(Reporter: Paulius, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

In the mozilla calendar program, wenever I want to disable or enable a calendar
the program simply stops responding, just like if a program is about to crash
but then all the Mozilla programs crash and after  about 20 seconds everything
is back to normal and the action I wanted to do is done.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla Calendar
2. At the upper left corner of the screen go to the "Calendars" tab
3. Enable or disable any of your calendars

Actual Results:  
All opened mozilla programs stop responding for 25 seconds. and after that it
enables or disables that calendar like I wanted.

Expected Results:  
enable or disable that calendar instantly

my computer is fast: widows xp pro and 1ghz processor

Comment 1

15 years ago
Works for me with the latest release on Win XP Pro.
(Reporter)

Comment 2

15 years ago
I don't have the service pack! Service packs ruin Windows... Makes work slower
and crashes a lot. My buid is 2600.
(Assignee)

Comment 3

15 years ago
Have you tried this with a new calendar as well? Create a new calendar ( with no
events ) and disable/enable it. If that works add a simple event and try again.
If that works too, attach the calendar file which causes the crash ( when
enabled ) to this bug. If you run Mozilla -console you will get more info in the
console window. See if there is anything useful printed out in the console at
the time of the crash.

Comment 4

15 years ago
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah
This bug is obsolete. Mostafa or the reporter should close it if it's now
reproducible. I cann't reproduce it at my win2k (700mhz) box.
(Assignee)

Comment 6

13 years ago
This is reproducable with large ics files that have a lot of recurring events.
Mostafa, 
Do you have any files that exhibit this bug you can attach? Should this bug be marked as new since you 
can duplicate it?

Comment 8

13 years ago
If this bug is about Calendar being unstable with large calendars, then this bug
should be duped against bugs which say exactly that.

Comment 9

13 years ago
I agree with Simon, if this bug is related to large .ics files, it should be
marked as a duplicate of bug 198142.  Reporter, have you tried the suggestion of
starting with a blank Calendar and trying to reproduce this bug?

Comment 10

13 years ago
No response from reporter.  The only reason this wasn't closed awhile ago was
due to Mostafa's comment about large .ics files, so I'm marking it a duplicate
of that bug, just as sipaq suggested.

*** This bug has been marked as a duplicate of 198142 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.