[FreeType2] Only the first Mozilla window is anti-aliased.

RESOLVED DUPLICATE of bug 181487

Status

Core Graveyard
GFX: Gtk
RESOLVED DUPLICATE of bug 181487
15 years ago
9 years ago

People

(Reporter: marcoos, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617

If you have FreeType2 anti-aliasing on in defaults/pref/unix.js, only the chrome
of the first window is anti-aliased (but the content is anti-aliased in all
windows).





Reproducible: Always

Steps to Reproduce:
1. Turn FreeType2 antialiasing on in your unix.js
2. Open Mozilla (any component, e.g. Navigator) under 
3. Open another Mozilla window
Actual Results:  
The newly-opened window has non-antialiased chrome.


Expected Results:  
All the Mozilla windows (not only the first-opened one) should use antialiasing
for chrome, if that is set in the unix.js.


This used to work properly in some earlier Mozilla's, but I can't remeber when
this bug came out -- Netscape 7 anti-aliases all windows, when FT is turned on.
(Reporter)

Comment 1

15 years ago
Created attachment 126071 [details]
Screenshot

A screenshot showing two Mozilla windows. The window with Bugzilla is the one
that Mozilla started with. The window showing 7thGuard.net was opened via
CTRL+N from the first one.

Comment 2

15 years ago
==> gtk
Assignee: kmcclusk → blizzard
Component: GFX → GFX: Gtk

Comment 3

15 years ago
Shouldn't this be a dupe of bug 181487?

It's a regression that appeared after the 2002111404 nightly build.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 181487 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.