Closed Bug 210121 Opened 21 years ago Closed 21 years ago

Popup filter blocks requested popup while image loading

Categories

(SeaMonkey :: UI Design, defect)

x86
Windows 98
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 101190

People

(Reporter: odi, Assigned: jag+mozilla)

Details

Attachments

(1 file)

579 bytes, text/html
Details
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

In the sample HTML page that I attach to this bug, the requested popup window
(by clicking on the link) is blocked by the popup filter while the image is loading.
If you wait for the image to load completely the popup works as expected.

In some situations I also noticed that Mozilla generates an OnUnLoad event when
opening or blocking the popup window.

Reproducible: Always

Steps to Reproduce:
1. Load the sample page
2. Do not wait for the image to complete loading but click the link.


Actual Results:  
a) The popup window that should appear is blocked by the filter.

b) In some situations the body.onUnLoad event is generated.

Expected Results:  
a) the popup window should appear, because the user requested it by clicking a link.

b) No onUnLoad event should be generated.

I consider this bug especially important because it renders the popup filter
unusable for people with a slow internet connections (i.e. long page load
times). They will most probably start clicking links before the page and all
images are fully loaded.
Attached file Test Page
Shows the problem
I believe this is due to the way popup blocking was implemented:
it's the pref |dom.disable_open_during_load|

At any rate, reassigning to XP Apps, as this is not a JavaScript
Engine issue. Looks like a duplicate of:

bug 101190
"window.open() in onclick, etc. fails while page is loading (if 
|dom.disable_open_during_load| pref is set to block popup ads)"
Assignee: rogerl → jaggernaut
Component: JavaScript Engine → XP Apps
QA Contact: pschwartau → paw
Resolving as duplicate. odi: if you disagree, please reopen. You will
be cc'ed on bug 101190 so you can follow progress on this issue -

*** This bug has been marked as a duplicate of 101190 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Yes, setting the pref to false resolves the problem. So it's a dupe.
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.