Closed Bug 210146 Opened 18 years ago Closed 5 years ago

muni.org - Selection of icon has no effect - IE expands icon to additional selections

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: skeller, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

Within the GIS mapping application, there is a text search selection. When using
IE, the operator is able to select the Text search icon and additional options
are expanded for selection.  With Mozilla, selecting the icon has no apparent
effect. 

Reproducible: Always

Steps to Reproduce:
1.browse to http://munimaps.muni.org/website/anchorage/application/disclaimer2.htm
2.Select Agree
3.Wait for the Anchorage map to be displayed in the right frame
4.Select the "search" tab in the upper left of the left frame
5.Select "Text Search Tools" in the middle of the left frame


Actual Results:  
Nothing happens.

Expected Results:  
Using IE, the selection expands to three choices for the search operation

This has been true for the past several versions of Mozilla; I would just pop
over to IE when I needed access to this application.  Obviously, I would prefer
not to use IE.  Unfortunately, if you can't get to the additional options,
you're unable to invoke a search.  Thanks.
The site has:

function expandIt(el) {
	if (!ver4) return;
	if (IE4) {expandIE(el)} else {expandNS(el)}
}

Where ver4 is defined as:

ver4 = (NS4 || IE4) ? true : false;

where those are defined as:

NS4=(document.layers) ? true : false;
IE4=((document.all)&&(bV>=4))?true:false;

Now Mozilla supports neither document.layers (something NS4 made up) nor
document.all (something IE made up), but does support the standard W3C DOM.  So
the problem is that this site, by design, does not work in any browsers but NS4
and IE (eg it will fail in Safari, and in most versions of Opera).
Assignee: saari → english-us
Status: UNCONFIRMED → NEW
Component: Event Handling → English US
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: desale → english-us
Hardware: PC → All
Version: Trunk → unspecified
Summary: Selection of icon has no effect - IE expands icon to additional selections → muni.org - Selection of icon has no effect - IE expands icon to additional selections
Bug is still present.
Assignee: english-us → nobody
Component: English US → Desktop
When going there, we get the following message.

> We apologize for the interruption of service for those customers that have become comfortable using the older "Parcel Information Viewer" mapping application. From public comments we quickly realized that this was one of the few applications we have that is usable by our Apple/Mac users. for these reasons we have placed the old "Parcel Information" application back into service. We plan on leaving this application available until we have a complete upgrade that works with the Safari browser on Apple/Mac PCs.
> 
> To go to the "Property Information Viewer" select this link (works with the Safari browser)
> 
> To go to the "Advanced Mapper" select this link. (works with the IE and Netscape browsers)

The Advanced mapper is giving me a 

> The web site you are accessing has experienced an unexpected error. Please contact the website administrator. 

The property information viewer is sending me to
http://munimaps.muni.org/website/anchorage/application/map.htm

with a 

> Unable to display MapService
> Server returned:AXLParser: 'maxy' not found in ENVELOPE.


This site is broken in many ways, not sure what to do here.
We are redirected now to 
http://muniorg.maps.arcgis.com/apps/Solutions/s2.html?appid=d98a480863e14e0eb61d6d7818c16e82

A map is displayed.
I searched for an address and got an answer. 

The domain being different, I will close this as invalid.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.