Option to collapse browser windows into one window

RESOLVED DUPLICATE of bug 102132

Status

SeaMonkey
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 102132
15 years ago
9 years ago

People

(Reporter: Thomas Winzig, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030603 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030603 Mozilla Firebird/0.6

A lot of times, after heavy browsing sessions, I will end up with more than one
Mozilla/Firebird window, each with one or more tabs. This happens for different
reasons -- sites that open links in new windows, followed by tabbed browsing in
those windows; a 3rd party app opening a new browser window instead of a tab; etc.

When this happens, things get confusing, as I don't remember which browser held
which tab, and I end up losing some of the usefulness of the tab feature. 

A nice feature would be to have an option to 'collapse' all the browser windows
into one window with multiple tabs, bringing things back to one window. Right
now I have 3 browser windows open. Two of them with two tabs, one with no tabs. 

I wish I could right click on the first browser window, and select "Collapse
Browser Windows," and have all the tabs moved to the current window, and the
other windows closed. If possible, this would not reload the pages that are
moved, they would just be re-displayed in the current window.

I think the option should appear in the context-sensitive popup when you right
click on a browser's content area, when you right-click on the program in the
task bar (in windows and other similar GUI's), and in the View menu.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Sounds like a good idea to me, but just in case you don't know you can set the
value of the option "browser.block.target_new_window" to true and it won't allow
sites to open links with the target attribute set. Won't work for JavaScript
links though and I don't know a way around them (other than with a plug-in I
can't remember the name of) so it still sounds like a good idea.
(Reporter)

Comment 2

15 years ago
Yeah I've used that option in the past, but usually forget to turn it back on. ;-)

Plus like you said, the javascript stuff still messes with it, 3rd party apps
mess with it, and honestly, occasionally I will start a new browser window up
instead of a new tab (usually if I'm reading Mozilla email, and I click on the
browser icon). 

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 102132 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.