libjavaplugin_oji.so is not detected nor can it be applied

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
16 years ago
8 years ago

People

(Reporter: root, Assigned: joshua.xia)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i386; en-US; rv:1.4) Gecko/20030617
Build Identifier: Mozilla/5.0 (X11; U; Linux i386; en-US; rv:1.4) Gecko/20030617

I am running FreeBSD 5.1-CURRENT .

The jre-plugin installs and runs fine on the previous two versions of mozilla
(1.4b and 1.4rc1 - I still have them on my machine).

With 1.4rc2 it seems to install, but can't be applied nor be detected by Help
--> Plugins. The plugins directory looks identical to those of 1.4b and 1.4rc1.
All other plugins (realplayer, acrobat-reader, flash) apply correctly.

Reproducible: Always

Steps to Reproduce:
1. install jre via download or manually
2. Try some webpage with java-applets
3.

Actual Results:  
I am requested to download jre

Expected Results:  
display java-applet

Comment 1

16 years ago
You have to use a gcc-3.2 based jre with mozilla 1.4rc2. See releases notes of it.

Or it is not for FreeBSD but only linux ?
(Reporter)

Comment 2

16 years ago
I didn't compile anything from source. I just downloaded mozilla's
linux-binaries and installed them in FreeBSD's linux-compatibility system (which
should behave like a RedHat, I believe).

Also I dont't use any native FreeBSD version of the jre.
I downloaded the linux-jre from netscape.

Comment 3

16 years ago
Well, so you should read release notes :

1) Mozilla 1.4rc2 is now built with  gcc 3.2.3 (type about:buildconfig in url bar)
2) JRE from NS should be 1.3.1 or 1.4.1. But there is a problem of compatibility
because this JRE is built using gcc 2.95.

http://www.mozilla.org/releases/mozilla1.4rc2/#new-issues

"These are items that have been added to the release notes since the last
milestone although the bugs themselves may have existed previously.

    * Mozilla 1.4 for Linux requires Sun J2SE v 1.4.2 Beta to run Java applets"

I am using Blackdown java and it works. I don't know if it is working with FreeBSD.

I think so this is not a mozilla bug. Closing bug as invalid ?!
yes, it's invalid

RC2 is now compiled with Gcc3.2 (which is 20% faster) and RC1 is compiled with
the old GCC2.95. You need a JRE that is also compiled with GCC3.2 if it should work.

Solutions :
JRE1.4.2 Beta or Blackdown.
See the plugindoc link in about:plugins for additional help

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

16 years ago
O.K.
Getting new java-stuff to run on FreeBSD will take some time. But that isn't
mozilla's fault.

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.