javascript page (re)load removes form contents from back/forward history

RESOLVED DUPLICATE of bug 140697

Status

()

RESOLVED DUPLICATE of bug 140697
16 years ago
10 years ago

People

(Reporter: sparr0, Assigned: radha)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

If you use the 'ScreenSize' selector on the page in question then all of the
data you have entered into the form is lost, even if you go Back.  I cannot be
more specific but I hope someone can narrow this down.

To be clear, I am not talking about the 'new' form being empty, I am talking
about the 'old' form being empty if you hit back after changing size.

Reproducible: Always

Steps to Reproduce:
1.  Visit page
2.  Type in a message
3.  Change ScreenSize
4.  Go Back
Actual Results:  
Empty form

Expected Results:  
Restored the form to the way it was before ScreenSize was changed
Confirmed on Linux.  As another simple test, just load the page, type something
in the textarea, then hit reload.  The text should be preserved, but is not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 2

16 years ago
this occurs because of the <form> between the <table> and <tr> and then the
hidden <input>s.

dupe of "Misplaced form element and hidden input element(s) break form value
restoration when pressing Back"

*** This bug has been marked as a duplicate of 140697 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: chrispetersen → docshell
You need to log in before you can comment on or make changes to this bug.