Kill -9 java_vm crashes mozilla

RESOLVED DUPLICATE of bug 102474

Status

Core Graveyard
Java: OJI
--
major
RESOLVED DUPLICATE of bug 102474
15 years ago
7 years ago

People

(Reporter: Richard Neill, Assigned: Joshua Xia)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

I quite often find that the java_vm plugin can lock up my system - it goes to
100% cpu and asks for more and more memory without limit. Sadly, a kill -9
java_vm also  takes mozilla (and a week's worth of open tabs) with it.

Is there any way to kill *just* java, while leaving the mozilla process alive?
There should be...

Reproducible: Didn't try

Steps to Reproduce:
I've seen this 3 times now on various websites. 



Expected Results:  
Kill -9 java_vm (or killall -9 java_vm) should only kill the misbehaving applet.
Furthermore, Mozilla should prvent any java application taking all available CPU
or > 100 MB of memory.

Comment 1

15 years ago
==> OJI
Assignee: general → joshua.xia
Component: Browser-General → OJI
QA Contact: general → dsirnapalli

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 102474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.