mouse hovering broken for dual monitors

RESOLVED DUPLICATE of bug 141599

Status

RESOLVED DUPLICATE of bug 141599
16 years ago
10 years ago

People

(Reporter: edmcman, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

When mozilla is placed in a secondary monitor, mouse hovering does not work. 
For instance, when clicking on a menu and moving the mouse down over a menu
option, it does not stay highlighted.  Rather, it is highlighted while the mouse
is moving, but it is unhighlighted immediately when it stops.

This happens for onHover events in pages, hovering over menus or buttons, and
just about anything that detects when the mouse is hovering over it.

My secondary monitor is placed to the left of the main one.  After just testing,
mozilla only exhibits this behaviour when the secondary monitor is to the right
of the main one.  If its to the right, it works fine.  My guess is the menu
click actually has a negative x value position and that's messing it up somewhere.

I am also using nVidia nView extensions.  I'll test without that on, but it
hasn't messed up any other programs.

Reproducible: Always

Steps to Reproduce:
1.Move secondary monitor completely to of primary monitor in display control panel
2.Move mozilla to the secondary monitor (the majority of it)
3.Move mouse over something that should detect hovering (menu for instance), and
stop mouse

Actual Results:  
Menu was highlighted while moving mouse, and then it went back to normal color
when the mouse stopped.

Expected Results:  
The menu should've stayed hightlighted.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 205220 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
there is even earlier bug report
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 141599 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.