Closed Bug 210282 Opened 20 years ago Closed 20 years ago

Download manager performance degrades too quickly with a large number of entries

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 161783

People

(Reporter: dv, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

The response time of the Ctrl-S save functionality and "Remove from list" within
the download manager seem to degrade at least linearly (possibly exponentially)
with the number of outstanding entries in the download manager list.

With several hundred entries lying about in my download manager, it would take
almost 10 seconds for Mozilla to respond to Ctrl-S. Furthermore, when I realized
the problem and cleared the download manager, it took almost an hour to do so
and the browser to come back to life. Having done so, Mozilla is a lot quicker
to save files once again.

Reproducible: Didn't try

Steps to Reproduce:
1. Clear the download manager 
2. Measure how long it takes to save a file (an inline image for example)
3. Download lots (hundreds?) of files and leave them in the download manager
4. Measure how long it takes to save a file now.

Actual Results:  
Mozilla stopped responding and used a ridiculous amount of CPU time when
"saving" files.

Expected Results:  
A responsive GUI.
The comments on bug 132755 suggest that the cause is a linear search in
downloads.rdf.
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 161783 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.