Could not backup nor use S/MIME if X509 cert DN contains non US ASCII CHAR.

RESOLVED DUPLICATE of bug 217305

Status

--
major
RESOLVED DUPLICATE of bug 217305
16 years ago
2 years ago

People

(Reporter: serge.aumont, Assigned: ssaux)

Tracking

Other Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

When using a certificat which distinguished name contains UTF8 chars like éà etc
the certificate can't be exported and smime can't be used. 

Reproducible: Always

Steps to Reproduce:
1.request a certificate for C=FR/O=XXX/CN=négaret and install it in mozilla
2.try to backup this certificat : don't work
3.try to use it for s/mime signature : don't work

Actual Results:  
backup certificat says "failed to create the PKCS#12 backup file for unknown reason"
S/MIME : the message is sent but not signed

Expected Results:  
manage this certificat as any other one.

The bug is the same with any other Mozilla version including internationalized
versions.

Comment 1

16 years ago
I'm seeing this too
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Could not backup nor use S/MIME if X509 cert DN contains non US ASCII CHAR. → Could not backup nor use S/MIME if X509 cert DN contains non US ASCII CHAR.
I think this bug is a duplicate of bug #217305, or the other way arround.

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 217305 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.