Text caret not visible when element behind element with text

RESOLVED DUPLICATE of bug 167801

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 167801
15 years ago
14 years ago

People

(Reporter: Jamie Thompson, Assigned: roc)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

The text caret dissappears when an element is behind it. I noticed it when using
a n absolutly positioned <img> with CSS properties set to allow a stretched
background image (if anyone wants to implement this properly for the background
css property...I'd be very happy :oD ). I then noticed that the text caret for
the form elements dissappeared. I tried changing the <img> to a <div>, and even
without the image, the same problem manifests itself (I also turned on text
caret browsing (F7) and the same problem is observed). I have made a simplified
test case that you can easily view the problem with.

Reproducible: Always

Steps to Reproduce:
1. Go to the url given above
2. Type in the text fields, observing the lack of caret
3. Move to a text field below the image, and observe the caret. Scroll the
contents and observe the caret dissappearing as it touches the image, whilst the
text box is otherwise displaysd correctly.
Actual Results:  
The caret dissappears behind the backgroup element.

Expected Results:  
Placed the caret at the z-index of the respective element, or at the very least
above all other elements.

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.