Closed Bug 210639 Opened 21 years ago Closed 21 years ago

Confirm tab close ignores "Close Window".

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jasonb, Assigned: jag+mozilla)

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030625
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030625

The recently checked in fix for bug 108973, that throws up a confirmation
dialogue when closing a window with open tabs, works in every case (Exit, close
window button, etc.) except for when you choose File->Close Window (or
Ctrl-Shift-W).

Reproducible: Always

Steps to Reproduce:
1. Open multiple tabs.
2. Use File -> Close Window.
Actual Results:  
The window (with all open tabs) is closed without any confirmation.

Expected Results:  
The confirmation box should have been presented.
Adding Tim to CC list since he worked on the patch for bug 108973.
Attached patch Catch the last close method (obsolete) — Splinter Review
grumble duplicated code grumble I wasn't observant enough grumble sorry
Comment on attachment 126477 [details] [diff] [review]
Catch the last close method

Sorry guys, I missed a code path. Can you spare a r+sr for a 2-liner?
Attachment #126477 - Flags: superreview?(jaggernaut)
Attachment #126477 - Flags: review?(neil.parkwaycc.co.uk)
Comment on attachment 126477 [details] [diff] [review]
Catch the last close method

Nit: use the file's style. In this case your code would look like:

  if (typeof(this.tryToClose) == "function" && !this.tryToClose())
    return;

sr=jag with that.
Attachment #126477 - Flags: superreview?(jaggernaut) → superreview+
Attached patch fix nits (obsolete) — Splinter Review
Old habits die hard.  Nits addressed.

Carrying over sr=jag.
Spoke with Neil some, and here is a slightly different approach. It's mostly
the same thing.

Not carrying anything over.
Attachment #126535 - Attachment is obsolete: true
Attachment #126477 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #126538 - Flags: review+
Attachment #126538 - Flags: superreview?(jaggernaut)
Comment on attachment 126538 [details] [diff] [review]
Slightly different approach

sr=jag
Attachment #126538 - Flags: superreview?(jaggernaut) → superreview+
Fix checked in.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: