Allocated memory grows but never shrinks back if windows and tabs are closed

VERIFIED DUPLICATE of bug 198806

Status

VERIFIED DUPLICATE of bug 198806
16 years ago
10 years ago

People

(Reporter: saherr1969, Assigned: jag-mozilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

It appears that if you open many many tabbed pages (windows,urls) and/or open
additional browser windows the amount of memory allocated to mozilla.exe in
Windows Task manager grows and grows.  I had surfed many and multiple sites that
spawned windows as well as the tabbed windows I created.  I close all but the
primary/first one I had open.  I happened to have a program that appeared to not
be responding so I went into task manager.  At that point I had upwards of
83,000 Kb allocated to mozilla.exe.  I went into mozilla and I had one tabbed
page open where the content of the entire page was no more than 200Kb.  

Reproducible: Always

Steps to Reproduce:
1.go to any URL
2.create a new tab for each link (ctrl+click) or roller on Intellimouse
3.open more and more tabs then close them.... 

Actual Results:  
memory is not totally released

In my latest test I had 34 Mb allocated prior to open and closing 40-50 tabs and
5 or 6 windows.  When I finished closing back down to the one window and two
tabs I started with my memory allocation was up to 58 Mb .

Expected Results:  
if i return to where i started as far as page open and same number of windows
and tabs.... then I would expect a similiar memory allocation as to where I
started.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 198806 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Stephen, one thing to try, is that AFTER you close all
the windows & tabs, and you are back to the start, is
to go in and clear your cache...  Theoretically that will
take you back to 34Mb

Edit->Preferences->Advanced->Cache : Clear Cache

Comment 3

15 years ago
V/dupe.
Status: RESOLVED → VERIFIED
QA Contact: pmac → benc
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.