dbl-click selects to the beginning of the line (Intellimouse)

VERIFIED DUPLICATE of bug 12764

Status

()

Core
Selection
P4
normal
VERIFIED DUPLICATE of bug 12764
19 years ago
17 years ago

People

(Reporter: Eugene Savitsky, Assigned: mjudge)

Tracking

({helpwanted})

Trunk
Future
x86
Windows 98
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I have an IntelliMouse. The wheel button is set to Double-Click.

The bug:

When I use whe wheel button in location bar it invert only a part of the URL
typed in (only to the cursor position. Expl: http://bugzilla.moz). "Normal"
double-click works +/-fine.
bryner - Is this one for you?

Comment 2

18 years ago
The problem here seems to be that we don't honor the Windows settings for mouse
behavior that well.  I'm not really sure how to do that.  I'll check around and
see if anyone can help with it.

Comment 3

18 years ago
This works fine for me. Setting the middle button to double click selects whole
words as it should. Unsetting the option in the windows control panel reverts
to the default behavior as expected. Maybe this is a bug with selection in the
url bar?

Comment 4

18 years ago
Reassigning all of leger's unscreened Browser-General bugs to nobody@mozilla.org
for pre-screening and triage.

Comment 5

18 years ago
ezh, bryner --- are you still seeing this on M13? I don't have an Intellimouse 
to check with. Thanks!
QA Contact: nobody → elig

Comment 6

18 years ago
This is most likely a duplicate of a selection bug that existed at one time.  I
also don't have an Intellimouse, so I can't exactly reproduce this.  The fact
that it's the wheel button should be irrelevant.  But unless anyone has an
objection, I'll mark this one WORKSFORME.

Comment 7

18 years ago
Wheel Mouse bug; QA assigning to Jan Carpenter.
QA Contact: elig → janc

Comment 8

18 years ago
I will take this bug.  I just emailed the reporter for an update on it.
Assignee: nobody → bryner

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 9

18 years ago
After I had reinstalled windows and installed Intellipoint 2.2 problem 
dissapered.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 10

18 years ago
Verified per reporter comments. 
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

18 years ago
I have it again after I have installed IntelliPoint 3.1.

I think there's some driver incompatibility.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

Comment 12

18 years ago
I'm not sure why this bug stayed assigned to me- should be an editor issue, the
fact that your middle button is a mousewheel is likely not relevant.
Assignee: bryner → brade
Status: REOPENED → NEW
Component: Browser-General → Editor
QA Contact: janc → sujay
(Reporter)

Comment 13

18 years ago
"The fact that your middle button is a mousewheel is likely not relevant."

Yep, thats true. :) Today I had 2.2 installed all was working well - I buyed 
Intellimouse explorer today, so I DL and installed 3.1. Now I have the same 
problem, as I had when I had 3.x installed before I reinstalled my system.

Comment 14

18 years ago
could someone describe what the bug is here?  I think it has something to do with 
double-clicking in the url bar but I don't see a test case.  If I don't get a 
testcase soon I will be forced to resolve this as invalid..
Keywords: pp

Comment 15

18 years ago
I see this on 2000030516, winNT.  I am using the 3.1 drivers for the IntelliEye.  
I not only see this in the url bar, but on any text selection.  Setting the 
wheel click to act as a double click then wheelclicking on any selectable text 
selects the text from the last space up to the click point instead of selecting 
all the text from one space to another.   For instance

URL bar says http://www.mozilla.org.
Wheelclick on the m .
only http://www.m is selected when http://www.mozilla.org should be.

If i do a plain double click, everything is fine.

Comment 16

18 years ago
mjudge
Assignee: brade → mjudge
Component: Editor → Selection
Summary: Intellimouse (3rd button?) → dbl-click doesn't work; stops selection at cursor (Intellimouse)
Target Milestone: M15
(Reporter)

Comment 17

18 years ago
Yep. Now I tryed uninstall IntellyPoint 3.1 and installed IP 2.2 wheel 
double click works as it should. But when I reinstalled the bug is present.

Thanks to kerz@en.com for explaining this problem on english (I need some 
exercises in english :(), but I see it in URL bar too.
Component: Selection → Editor
Summary: dbl-click doesn't work; stops selection at cursor (Intellimouse) → Intellimouse (3rd button?)
Target Milestone: M15

Comment 18

18 years ago
is this another case of the mouse moving very slightly while double-clicking?
Component: Editor → Selection
Summary: Intellimouse (3rd button?) → dbl-click selects to the beginning of the line (Intellimouse)
Target Milestone: M15

Comment 19

18 years ago
P4
Priority: P3 → P4

Comment 20

18 years ago
moving out to M18
Target Milestone: M15 → M18

Comment 21

18 years ago

*** This bug has been marked as a duplicate of 23784 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 22

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 23

18 years ago
This is not a dup of 23784.

Here we have troubles only with Intellipoint 3.x mouse drivers (this trouble is 
only in Mozilla).

I bet 1000$ under Linux there's no Intellipoint, but 23784 is under Linux. 23784 
 is about selecting word with dbl-clk, this bug is for selecting a word with 
a wheel, setted-up for dbl-clk.

Read my first bug description - "normal" dbl-clk works normal, but wheel does 
not.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 24

18 years ago
per beppe. want to add threshold.
Status: REOPENED → ASSIGNED
Keywords: pp → correctness, nsbeta3
Target Milestone: M18 → M19

Updated

18 years ago
Keywords: nsbeta3

Comment 25

18 years ago
moving to future and adding helpwanted
Keywords: correctness → helpwanted
Target Milestone: M19 → Future

Comment 26

18 years ago
I have insight into what may be the problem. I was just about to report this but
figured it'd be better to search for it, and viola, it existed. I've narrowed it
down to *speed*. I can reproduce the double clicking behavior that setting a
double click button does when I double click *really fast*, manually. Since the
Intellimouse does this very quickly, this is probably what the problem is.
Applies to all text as kerz said, not just URL bar.

Comment 27

18 years ago
nevermind, I deem my previous conclusion silly, and I was just experiencing the 
bug where double-clicking and slightly moving the cursor would select up to the 
cursor position. Nevertheless, extremely annoying, not a day goes by where I 
don't experience this.

Comment 28

17 years ago
*** Bug 63882 has been marked as a duplicate of this bug. ***

Comment 29

17 years ago
cc'ing self...sorry for the junk mail...
(Assignee)

Comment 30

17 years ago
this is all from twitching mouse while double clicking. it makes the same 
effect. i have some ideas i will try to get into 9.3

*** This bug has been marked as a duplicate of 12764 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 31

17 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 32

17 years ago
*** Bug 91644 has been marked as a duplicate of this bug. ***

Comment 33

17 years ago
Hey, I think this bug still exists and it's not a dup of bug 12764 because that
bug is only for linux.  Furthermore, as cleared up later, this bug can happen
from doubleclicking really fast without using intellimouse as a doubleclick
button, so the summary should be changed.  (see my comments in bug 91644 )

Comment 34

17 years ago
I just marked bug 12764 as All/All.
You need to log in before you can comment on or make changes to this bug.