Can't import Eudora folders with illegal filenames such as slash (/)

RESOLVED DUPLICATE of bug 131013

Status

MailNews Core
Import
RESOLVED DUPLICATE of bug 131013
15 years ago
10 years ago

People

(Reporter: Lorrin Nelson, Assigned: Cavin Song)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Eudora allows you to give your folders names that are not legal filenames, such
as "Servlet / JSP". Eudora saves the folder on disk without the illegal
character (it just leaves it out, ie "Servlet JSP.fol") but places the full name
of the folder in the binary .toc file. To successfully import the folder into
Mozilla Mail, you need to open the .toc file and change the name of the mailbox
to not include any characters that can't be part of a filename.

Reproducible: Always

Steps to Reproduce:
1. Create Eudora folder with a slash (/) in the name
2. Try to import the folder into Mozilla
3.

Actual Results:  
Import fails, Mozilla gives error message saying it can't create the file on disk.

Expected Results:  
Mozilla should recognize that the folder name contains illegal characters and
rename it, perhaps by just leaving out the illegal characters and using the name
Eudora used.

Comment 1

15 years ago
reporter, is this dupe of bug 131013?
(Reporter)

Comment 2

15 years ago
yes; sorry I didn't catch 131013 when I was looking for previously filed bugs.
It looks like the this is a little different (I saw a different error message)
and there's a different workaround (edit the Eudora .toc file), but it sounds
like the same underlying problem.

Comment 3

15 years ago
Dupe as per comment #2

*** This bug has been marked as a duplicate of 131013 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.