Send mail hangs when browser dialog box is open

VERIFIED DUPLICATE of bug 74331

Status

defect
--
minor
VERIFIED DUPLICATE of bug 74331
16 years ago
10 years ago

People

(Reporter: peter, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I tried to send a message I had finished composing. Send hangs with the status
line "Assembling mail information". After some time (wondering if the message I
had written was lost) I discovered that a browser download which I was doing in
the background had opened a dialog box, but this had not been displayed. As soon
as I responded to the dialog box, the send completed correctly.

Reproducible: Always

Steps to Reproduce:
1. Compose a message
2. In the browser, start a download which will open an "Enter name of file to
save to" dialog
3. Switch back to the compose window,  without necessarily waiting for the
dialog to appear, certainly without closing the dialog
4. Click "send" in the compose window

Actual Results:  
The compose window hangs with the status line "Assembling mail information".

Expected Results:  
The message should be sent as normal, independent of the browser state. Or,
failing that, the browser dialog which needs to be closed first should appear on
the screen so that the problem is obvious.

An apparently minor problem which may well confuse users, especially beginners,
and cause them not to trust the program.

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.