Ability to use both AND and OR in filters

RESOLVED DUPLICATE of bug 59821

Status

--
enhancement
RESOLVED DUPLICATE of bug 59821
16 years ago
11 years ago

People

(Reporter: rameshkumarp, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Message Filter should provide "AND OR Combination". 
(ex)  ((Rule1) OR (Rule2)) AND (Rule3) .

At present UI does not support this. Is there any so that editing
msgFilterRules.dat file will support the above condition?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Seems reasonable to me. Changed Hardware/Os -> ALL. Changed summary to reflect
the nature of the request. Changed severity to "enhancement"
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: AND OR Combination → Ability to use both AND and OR in filters

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 59821 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.