Buy.com: logging in opens tabs and forces multiple attempts to log in

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: don, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: needs to reproduce on Linux, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030616 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030616 Mozilla Firebird/0.6

When I want to peruse my buy.com login, I go to their site and try to login. 
After I enter my login info and submit it, a new Untitled tab opens and does
nothing.  I go back to the original tab, where my info is gone.  I enter it
again and a new Untitled tab is opened.  This time however the original tab is
now logged in and I'm at the profile screen as expected.  This only works when
the login is valid.  I've tested with bunk login info and it doesn't open new tabs.

Reproducible: Always

Steps to Reproduce:
1. Go to http://buy.com
2. Click on the "my account" button in the upper-right
3. Attempt to log-in (requires existing buy.com login)

Actual Results:  
New tab opened up with nothing.  Went back to original tab and tried to log in
again.  After that a third tab opened and the original tab was then logged in to
buy.com.

Expected Results:  
Just log in right away and not open tabs for no reason.

Comment 1

15 years ago
This works for me using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5a)
Gecko/20030630 Mozilla Firebird/0.6

I remember some weird problems where pages opened in a new tab on Linux, but I
think they dealed with the URL bar...

Nevertheless did you already tried with a vanilla profile or is an old one? If
so, try creating a new profile by calling Moz.Firebird with option "-p" just to
make sure problem is not caused by some extensions or a corrupt environment.
(Reporter)

Comment 2

15 years ago
I moved my .phoenix folder to _phoenix_old and tried again.  Same exact behavior
as before.  As my initial report states, I'm using Firebird 0.6 on Linux.

Comment 3

15 years ago
Don, I knew you're using Linux! :o) But it's necessary to know, if this is a
platform / OS independent issue or not.

My question concerning a new profile was just because you didn't mention that
you already tried with a fresh profile - if you'd go through bugzilla and search
for bugs resolved as "WFM" and check the large number of bugs just caused by
corrupt profiles you'd probably get an idea on why I've asked you to create a
new one - though it didn't help you in this case... :)

=> adding keywords & waiting for someone with Linux to confirm this...

btw: do you see this also using latest SeaMonkey?
Keywords: qawanted
Whiteboard: needs to reproduce on Linux
Marking worksforme, no response from bug reporter, no confirmation or duplicates
found.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

15 years ago
Sorry if you thought I was away.

Anyway I just confirmed this bug still exists with mozilla-firebird-0.6.1.  This
is on both my home and work desktop machines.  Both run Gentoo linux.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

15 years ago
I can have some of my co-workers (also gentoo linux users) to confirm this if
they use mozilla firebird.  I'll report back in tomorrow.

Comment 7

15 years ago
I can confirm that this is happening in Firebird 0.6.1 (Mozilla/5.0 (X11; U;
Linux i686; en-US; rv:1.5a) Gecko/20030804 Mozilla Firebird/0.6.1), compiled
from source.

Don't know if this matters, but here are the flags specified with configure
(compiled w/ gcc 3.2.3):
--disable-composer \
      --with-x \
      --with-system-jpeg \
      --with-system-zlib \
      --with-system-png \
      --with-system-mng \
      --disable-mailnews \
      --disable-calendar \
      --disable-pedantic \
      --disable-svg \
      --enable-mathml \
      --without-system-nspr \
      --enable-nspr-autoconf \
      --enable-xsl \
      --enable-crypto \
      --enable-xinerama=no \
      --with-java-supplement \
      --with-pthreads \
      --with-default-mozilla-five-home=/usr/lib/MozillaFirebird \
      --with-user-appdir=.phoenix \
      --disable-jsd \
      --disable-accessibility \
      --disable-tests \
      --disable-debug \
      --disable-dtd-debug \
      --disable-logging \
      --enable-reorder \
      --enable-strip \
      --enable-strip-libs \
      --enable-cpp-rtti \
      --enable-xterm-updates \
      --enable-optimize=-O2 \
      --disable-ldap \
      --disable-toolkit-qt \
      --disable-toolkit-xlib \
      --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help \
      --enable-toolkit-gtk \
      --enable-default-toolkit=gtk \
      --disable-toolkit-gtk2 \
      --enable-xft --disable-freetype2

Comment 8

15 years ago
Actually, I just found out about about:buildconfig, so here's a more "official"
config:

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r1, propolice) 	-Wall -W
-Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -march=pentium3 -O3
-pipe -Wno-return-type -w -Wno-return-type -w -Wno-return-type -w -s
-fforce-addr -pthread -pipe
g++ 	gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r1, propolice) 	-frtti
-fno-handle-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-long-long -O2
-mcpu=i686 -pipe -Wno-return-type -w -Wno-return-type -w -Wno-return-type -w -s
-fforce-addr -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
--localstatedir=/var/lib --disable-composer --with-x --with-system-jpeg
--with-system-zlib --with-system-png --with-system-mng --disable-mailnews
--disable-calendar --disable-pedantic --disable-svg --enable-mathml
--without-system-nspr --enable-nspr-autoconf --enable-xsl --enable-crypto
--enable-xinerama=no --with-java-supplement --with-pthreads
--with-default-mozilla-five-home=/usr/lib/MozillaFirebird
--with-user-appdir=.phoenix --disable-jsd --disable-accessibility
--disable-tests --disable-debug --disable-dtd-debug --disable-logging
--enable-reorder --enable-strip --enable-strip-libs --enable-cpp-rtti
--enable-xterm-updates --enable-optimize=-O2 --disable-ldap --disable-toolkit-qt
--disable-toolkit-xlib
--enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help
--enable-toolkit-gtk --enable-default-toolkit=gtk --disable-toolkit-gtk2
--enable-xft --disable-freetype2 --enable-old-abi-compat-wrappers
(Reporter)

Comment 9

15 years ago
Ah cool.  Here is my about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r2, propolice) 	-Wall -W
-Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -march=pentium3 -O3
-pipe -Wno-return-type -w -Wno-return-type -w -Wno-return-type -w -s
-fforce-addr -pthread -pipe
g++ 	gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r2, propolice) 	-frtti
-fno-handle-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-long-long
-march=pentium3 -O3 -pipe -Wno-return-type -w -Wno-return-type -w
-Wno-return-type -w -s -fforce-addr -fshort-wchar -pthread -pipe
-I/usr/X11R6/include

Configure arguments
--prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
--localstatedir=/var/lib --disable-composer --with-x --with-system-jpeg
--with-system-zlib --with-system-png --with-system-mng --disable-mailnews
--disable-calendar --disable-pedantic --disable-svg --enable-mathml
--without-system-nspr --enable-nspr-autoconf --enable-xsl --enable-crypto
--enable-xinerama=no --with-java-supplement --with-pthreads
--with-default-mozilla-five-home=/usr/lib/MozillaFirebird
--with-user-appdir=.phoenix --disable-jsd --disable-accessibility
--disable-tests --disable-debug --disable-dtd-debug --disable-logging
--enable-reorder --enable-strip --enable-strip-libs --enable-cpp-rtti
--enable-xterm-updates --enable-optimize=-O2 --disable-ldap --disable-toolkit-qt
--disable-toolkit-xlib
--enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help
--enable-toolkit-gtk --enable-default-toolkit=gtk --disable-toolkit-gtk2
--enable-xft --disable-freetype2 --enable-old-abi-compat-wrappers 
Ok, more than one person is seeing this -> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
QA Contact: asa
(Reporter)

Comment 11

15 years ago
This is still happening in 0.7, which I would expect since you didn't say it was
fixed.  ;)

Anyway just some more case studies.  The behavior described in the original
comment is when attempting to login on a single window with no tabs.

HOWEVER, if I open a second tab in a window (let's say the first tab is on
slashdot or something) and use that to log in, then a third blank tab will be
opened, but the second tab will log in right away.

Now if I have two tabs already open (let's say google news and slashdot) and go
to buy.com on the third tab and login, it opens a fourth tab (blank) and logs in
right away on the third tab, so it is the same as the second tab scenario in
that it opens one new tab and logs in right away.
question on this: if you try in mozilla, can you find out what link is getting
called?  specifically looking for | characters, which break URLs in Firebird due
to how we handle multiple homepages...
QA Contact: mconnor

Comment 13

15 years ago
I have been seeing this for a long while now but just got around to looking to
see if there was a bug filed since I am still seeing it in Firefox 0.8.

And I am seeing this on Win2000 by the way so OS needs to be moved to All.

There is a way to get the page to work "right" and "wrong" depending on how you
_submit_ the page.  For both ways, go to the login page
(https://secure.buy.com/corp/support/login.asp).  Enter any email address and
password string (if you use real account info you will be logged in, fake info
will bring up a "no account info found" but both will show the results).

Now, to get the new tab "wrong" action, hit enter in the password field.

If you want the "right" action, do not hit enter and click on the Login button.

For some reason these two ways to submit the form get treated differently.
(Reporter)

Comment 14

15 years ago
I can duplicate David Evola's results.  Clicking the "Login" button evokes
desired behavior.  Hitting "return" opens new tab, while original tab is still
not logged in.  Nutters.
(Reporter)

Comment 15

15 years ago
Forgot to note that this is with Mozilla Firefox 0.8.0 on linux (gentoo).

Comment 16

14 years ago
Is this bug still holding on for dear life on 0.9.1?  
Flags: blocking-aviary1.0?
Keywords: qawanted

Comment 17

14 years ago
It looks like the page is behaving correctly now for me.  
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Can someone else try as well?
(Reporter)

Comment 18

14 years ago
Yes!  I confirm that this is now working in firefox 0.9.1 as should be with just
the one tab/window.

I'm resolving FIXED.  Hope I'm not over-stepping my bounds.
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Flags: blocking-aviary1.0?
You need to log in before you can comment on or make changes to this bug.