composing message with RTL paragraph directionality - problems moving cursor

RESOLVED DUPLICATE of bug 207186

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 207186
15 years ago
10 years ago

People

(Reporter: Uri Dor, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({rtl})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

when I compose a message in Hebrew (or reply to such a message) and set the
"DIR" attribute to "RTL" as specified in #96057, movement between lines is erratic:
1. arrow up doesn't reach the beginning of the message (sometimes). instead it
stops where the quotation of the message replied to begins
2. ctrl+home doesn't reach the beginning (although ctrl+end does reach the end)
3. if some text in English is reached while repeatedly pressing arrow right, the
cursor gets into a loop; arrow left causes the cursor to halt at end of line
4. 

Reproducible: Always

Steps to Reproduce:
1. compose new message
2. format / page colors and background / advanced edit
3. attribute = dir, value = rtl
4. ok, ...
5. type text in Hebrew (use alt+shift to switch) in several lines
6. try to navigate in the text
Actual Results:  
described in details

Expected Results:  
should navigate correctly
(Reporter)

Comment 1

15 years ago
delete word (ctrl+backspace) is screwed too

Comment 2

15 years ago
Are these problems specific to RTL/Hebrew or general?  I'd look for duplicates
under Browser | Selection

Comment 3

15 years ago
"Me Too" (tm). Happens with Bidi text only. Never seen it with non-Bidi;
seen in all versions, not just 1.4.

Comment 4

15 years ago
I believe that this is a dupe of Bug 207186 ("Moving the caret in BiDi texts is
buggy, especially in right-to-left forms").

Prog.
(Reporter)

Comment 5

15 years ago
I agree

*** This bug has been marked as a duplicate of 207186 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
Uri Dor in Comment #1:

> delete word (ctrl+backspace) is screwed too

That's bug 209430 ("Accel+Delete and Accel+BackSpace delete in the wrong direction")

Prog.
Product: MailNews → Core

Comment 7

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.