going from page to specific message and back to page it goes back to the top of the page

RESOLVED DUPLICATE of bug 215405

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 215405
15 years ago
12 years ago

People

(Reporter: Judy Ranelli, Assigned: Adam Lock)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

boatertalk is a message board.  in IE if I am a third of the way down the main
page and I click on a message to read it, then hit 'back' to go to the main page
again, it stays where I was reading.  Mozilla goes back to the top of the page,
and then I have to manually scroll down and find where I was.  It's confusing
and so for the time being I'm using Mozilla's email but IE for browser.  I'd
like to be rid of IE totally!  Can you fix this?

Reproducible: Always

Steps to Reproduce:
1.go to www.boatertalk.com
2.Scroll down half the page and click on a message.
3.click 'back' to go back to the main page.

Actual Results:  
I was back at the top of the page.

Expected Results:  
It should have gone back to the section of the page I was reading.

Comment 1

15 years ago
I come up with the same problem (WinXP/Firebird 0.6) on pretty much any
dynamically generated page, though hopping between static pages does not produce
the problem.  Red herring or helpful clue - you make the call.

Still, it would be nice to see this behave in a more IE-oriented way.

Comment 2

14 years ago
->Docshell maybe?
Assignee: general → adamlock
Status: UNCONFIRMED → NEW
Component: Browser-General → Embedding: Docshell
Ever confirmed: true
QA Contact: general → adamlock

Comment 3

14 years ago
Is there any activity on this bug? It's very annoying when reading forums,
looking through auctions, etc. It still exists in 1.7RC3.

I find that it doesn't happen every time, but probably about half the time. I
haven't been able to reproduce it 100%.

Comment 4

14 years ago
(In reply to comment #0)
Same problem. FireFox 1.0PR and RC on Windows 2000 SP4. Forums, eBay, and even
FireFox's Extensions pages. Click on a link, hit the back button, you're back at
the top. Hit refresh, same thing, back at the top.
Could someone do an HTTP log of the affected page's load following the instructions at 
http://www.mozilla.org/projects/netlib/http/http-debugging.html and attach it to this bug 
using https://bugzilla.mozilla.org/attachment.cgi?bugid=211242&action=enter ?

Comment 6

14 years ago
I tried to go through about 100 links with 1.7.5 and couldn't reproduce the
problem. Maybe it's fixed now in 1.7.5?
Well, if the problem is gone, the bug should probably be marked "worksforme"....

Comment 8

13 years ago
I still see this bug on trunk (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8b) Gecko/20050115 Firefox/1.0+)

1. Visit this link http://www.boatertalk.com/forum/BoaterTalk
2. Scroll down the page
3. Click on any thread and press back.
4. You'll end up at the top of the original page.

Comment 9

13 years ago
Created attachment 171395 [details]
HTTP log (zipped)

as requested.. Hope I've done it right.
The relevant header from that log is:

  Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0


*** This bug has been marked as a duplicate of 215405 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.