ONMOUSEOUT event is fired when the first MOUSEDOWN is performed (Linux only)

RESOLVED DUPLICATE of bug 102578

Status

()

RESOLVED DUPLICATE of bug 102578
16 years ago
16 years ago

People

(Reporter: jfeit, Assigned: saari)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

The following code will define some events. When clicking the link, the MOUSEOUT
and MOUSEDOWN are fired. The problem occurs only when the link is clicked *for
the first time*
Comment/uncomment the alert actions to see the problem.

This bug was tested on Mozilla 1.3, 1.4 on Linux RH 9.
Mozilla 1.3, 1.4 on W2000, W98 worked fine. (MSIE behaves as expected).

This bug prevents creating JavaScript controlled menus (with mouse controlled
highlighting of the items etc.)

<HTML>
<HEAD>
<SCRIPT>
function on_click(){
   //alert("ONCLICK");
}
function on_mouseover(){
   //alert("ONMOUSEOVER");
}
function on_mouseout(){
   alert("ONMOUSEOUT");
}
function on_mousedown(){
   //alert("ONMOUSEDOWN");
}
</SCRIPT>
</HEAD>
<BODY>
<A HREF="javascript: void 0"
   ONCLICK="on_click();"
   ONMOUSEOVER="on_mouseover();"
   ONMOUSEOUT="on_mouseout();"
   ONMOUSEDOWN="on_mousedown();"
>Test for mouseevents</A>
</BODY>
</HTML>

Reproducible: Always

Steps to Reproduce:
1. open the above given HTML snippet (Mozilla, Linux RH 9)
2. click on the link
3.

Actual Results:  
the FIRST click fires the MOUSEOUT event, other clicks are OK

(and the event seems to be somehow incomplete, the follownig correctly
fired MOUSEDOWN cannot detect the previous event, but here I am not sure, but
this is probably not important)

Expected Results:  
MOUSEDOWN should not fire the MOUSEOUT event (OK in Windows builds)

Linux RH 9, M. 1.3 , 1.4 BUG
Windows 2000, 98, M 1.3 , 1.4 OK
MSIE OK

other operating systems were not tested

Comment 1

16 years ago
dupe of "Clicking wrongfully fires onmouseout"

*** This bug has been marked as a duplicate of 102578 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.