XML document transformed with XSLT causes browser to spin continuously

RESOLVED DUPLICATE of bug 202765

Status

()

RESOLVED DUPLICATE of bug 202765
16 years ago
16 years ago

People

(Reporter: j_yunker, Assigned: peterv)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.3) Gecko/20030321
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.3) Gecko/20030321

There are some similarities to Bug #202765, but this example does not
crash the browser, it just causes it to never load the page nor indicate
when the page is finished loading.

The comments in defect #202765 mention that document.write()
is not supported, this example does use document.write().

I've enclosed a sample piece of xml with an xsl transform that contains
dynamic HTML.  When you attempt to load 'test.xml', the following exception
occurs in the javascript console.

Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"
 location: "JS frame :: chrome://navigator/content/nsBrowserStatusHandler.js ::
anonymous :: line 350"  data: no]
Source File: chrome://navigator/content/nsBrowserStatusHandler.js
Line: 350

The browser acts as if the page is loading, but no further data is displayed.
The exception occurs when the xsl attempts to write a value via 
document.write(strHTML).  This example fails on HPUX as well.

The enclosed code works on IE and outputs the following:

value f1				has a value


Reproducible: Always

Steps to Reproduce:
1.  Save the attached files 'test.xml' & 'test.xsl' to a local directory.
2.  Attempt to open 'test.xml' in the browser
Actual Results:  
An exception appears in the javascript console, the page appears blank,
and the Mozilla icon 'spins' as if a page is loading, but nothing is
ever returned.

Expected Results:  
The page should finish loading the XML and
the following output should be displayed:

value f1				has a value
(Reporter)

Comment 1

16 years ago
Created attachment 126961 [details]
The XML file that causes the browser to spin.
(Reporter)

Comment 2

16 years ago
Created attachment 126962 [details]
The XSL transform that is applied to the XML.

Comment 3

16 years ago
doesn't really matter if I dupe or invalid this one.
document.write is not supported and won't be. (It will actually error soon, I 
hope, by bug 202765.)
I do intend to add an item to the FAQ about this. Yeah, me and writing docs, sad
story, sorry.

*** This bug has been marked as a duplicate of 202765 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.