NS_FRAME_SYNC_FRAME_AND_VIEW is unused

RESOLVED DUPLICATE of bug 287338

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 287338
15 years ago
13 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

NS_FRAME_SYNC_FRAME_AND_VIEW is set and cleared in the frame state in a few
places. However, it is never tested for. We may as well just remove it and all
the code that sets it. This frees up a global frame state bit, woohoo!

I noticed this because nsListControlFrame::MoveTo is overridden specifically to
set this bit, but that method hasn't been called in a VERY long time...

Comment 1

15 years ago
> This frees up a global frame state bit, woohoo!

Same story with NS_FRAME_HAS_LOADED_IMAGES
http://lxr.mozilla.org/seamonkey/search?string=NS_FRAME_HAS_LOADED_IMAGES

And NS_FRAME_HAS_VIEW now seems of dubious value as well (nobody set it):
http://lxr.mozilla.org/seamonkey/search?string=NS_FRAME_HAS_VIEW

That will bring the total to a whopping 3 state bits...

Comment 2

15 years ago
errata, make it 2. I made a typo when LXR'ing NS_FRAME_HAS_VIEW.
(In reply to comment #1)
> Same story with NS_FRAME_HAS_LOADED_IMAGES
> http://lxr.mozilla.org/seamonkey/search?string=NS_FRAME_HAS_LOADED_IMAGES

This one doesn't exist anymore.

*** This bug has been marked as a duplicate of 287338 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
No longer depends on: 97934
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.