Cursor movement in message composition with wrapped lines does not work correctly

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: Bernd Nies, Unassigned)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030703
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030703

This bug exists on Solaris 8 (and maybe other versions) since Mozilla 1.0 and
probably before.

When writing plain text emails with long lines that get wrapped and moving
around with the cursor, inserting and deleting some words then after a short
time the cursor movement with the arrow keys does not behave as expected:

- left does not move
- right jumps to next line
- up/down works
- home/end works

On the first unwrapped line the left/right cursor movement works on the
following wrapped lines it does not until you hit the return key to start a new
paragraph.

This also happens with wrapped lines in this HTML form textarea and it also
happens with the HTML mail message editor. I'v only seen this bug on the Solaris
build with pre-compiled binaries and with binaries build by myself from source

Reproducible: Always

Steps to Reproduce:
1. Open message composition window
2. Start writing text until it gets wrapped around and write some more lines
3. Try moving left/right up/down with the arrow keys on the 

Actual Results:  
Cursor left does not move, cursor right jumps to new line

Expected Results:  
Moving one character left or one character right.

Comment 1

15 years ago
Works perfectly fine for me on Solaris 8/9.

   Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5a) Gecko/20030611

Can you try a cvs build (1.5a mozilla) ?
(Reporter)

Comment 2

15 years ago
I downloaded the Solaris 2.7 nightly build from
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

mozilla-sparc-sun-solaris2.7.tar.gz        04-Jul-2003 03:35  17.1M  

The problem still exists. But it's not always the same anyway. Sometimes the
cursor left does not move back, sometimes it jumps to the begin of the
paragraph, sometimes to the previous line, then for a fragment of the wrapped
paragraph it works. One common thing: it always behaves oddly when the lines get
wrapped automatically. When terminating each line with a carriage return it
works as in every other editor.

The problem occurs with 
- Browsers: Mozilla 1.3, 1.4a, 1.4rc1, 1.4, nightly build, Netscape 7.0
  (plain text message editor and HTML textarea forms)
- OS: Solaris 8, Solaris 9
- Window Managers: CDE 1.4, CDE 1.5, twm, GNOME, fvmwm95

Comment 3

15 years ago
I can confirm that i have the same problem with my Forte 7 builds of Mozilla
1.3.1 and 1.4 when using gtk 1.2.10 (Forte compiled) and compiling with Forte 7.
The problem does'nt happen on gtk2 (gtk2.2.2 - Forte compiled) builds of Mozilla
1.3.1 or Mozilla 1.4 when using the GNOME 2 environment.
Looks like a general gtk 1.2.10 bug rather then a composer specific issue.

Updated

15 years ago
OS: SunOS → Solaris

Comment 4

15 years ago
When checking previous Mozilla bug i've noticed this one has already been 
logged a while back.
This bug is a duplicate of Bug #208765

Comment 5

15 years ago
This appears to be a duplicate of the old (Nov last year) bug -
http://bugzilla.mozilla.org/show_bug.cgi?id=178735

Though the comment here about it maybe being a gtk 1.2 issue is rather interesting.

Does anyone have a Forte gtk 2.2 build to try?

Or does anyone know how to build a gcc optimised Solaris build (last time I
tried, it failed badly, so someones about:buildconfig would be ace).

Comment 6

14 years ago
This seems to be the problem discussed under bug id 188288 where a connection to
CTL is made.  Apparently, when built with --enable-ctl the bug has appeared for
a long time --- already in mozilla 1.4 and possibly before that, still in
mozilla 1.5 and 1.6.

Hope this helps,

Nils.
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: esther → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 9

7 years ago
(In reply to comment #4)
> When checking previous Mozilla bug i've noticed this one has already been 
> logged a while back.
> This bug is a duplicate of Bug #208765

given that two people commented about the matching bug(s), this should have been fixed in bug 188288
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.