Segfault when trying to read a .ttf witouth enough perms

RESOLVED DUPLICATE of bug 183729

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 183729
15 years ago
13 years ago

People

(Reporter: Lucas Moreno Encabo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686) Gecko/20030704 Galeon/1.3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030704 Galeon/1.3.5

When mozilla tries to read a font file which does'nt have read perms, that
generates a segfault:


Reproducible: Always

Steps to Reproduce:
1.Try to load any page
2.
3.

Actual Results:  
Mozilla crash with a segfault

Expected Results:  
Mozilla should have ignored that font if it can't be read


open("/usr/share/fonts/windows/arial.ttf", O_RDONLY) = -1 EACCES (Permission denied)
munmap(0x420cb000, 58736)               = 0
--- SIGSEGV (Segmentation fault) ---

*** This bug has been marked as a duplicate of 183729 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.