FTP URL doesn't acknowledge requests for TYPE change

RESOLVED WONTFIX

Status

()

Core
Networking: FTP
--
trivial
RESOLVED WONTFIX
15 years ago
12 years ago

People

(Reporter: Michael Newton, Assigned: dougt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-CA; rv:1.4b) Gecko/20030612 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-CA; rv:1.4b) Gecko/20030612 Mozilla Firebird/0.6

Sorry about the vague title, it was the best I could think of.
RFC 1738 says:

---------------------
3.2.2. FTP url-path

   The url-path of a FTP URL has the following syntax:

        <cwd1>/<cwd2>/.../<cwdN>/<name>;type=<typecode>

   Where <cwd1> through <cwdN> and <name> are (possibly encoded) strings
   and <typecode> is one of the characters "a", "i", or "d".  The part
   ";type=<typecode>" may be omitted. The <cwdx> and <name> parts may be
   empty. The whole url-path may be omitted, including the "/"
   delimiting it from the prefix containing user, password, host, and
   port.

<snip>
      If the typecode is "d", perform a NLST (name list) command with
      <name> as the argument, and interpret the results as a file
      directory listing.

      Otherwise, perform a TYPE command with <typecode> as the argument,
      and then access the file whose name is <name> (for example, using
      the RETR command.)
---------------------

However, in Firebird, adding ;type=d to the end of a URL has no effect.  I
couldn't see a way to tell the difference between binary and ascii transfers, so
I don't know if ;type=a or ;type=i has any effect.
Additionally, if the type specification is added to a directory name (not
something you would need to do, but it is allowed by the RFC) it causes problems
with browsing, as subsequent directory/file names are added to the end of the
URL (after the typecode.)

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
This could at least be marked WONTFIX, or some acknowlegement!

Comment 2

13 years ago
I've recently encountered this problem, too.

I've been testing on a RH9 Linux server, using WU-FTPD "Version
wu-2.8.0-prerelease(1) Tue Apr 29 16:55:54 CDT 2003". I have an ASCII text file
on the server called "pfiboot.exec" (a REXX script) that contains lines of text
delimited by LF (0x0a) characters. I'm using "Mozilla/5.0 (Windows; U; Windows
NT 5.0; en-US; rv:1.7) Gecko/20040616" as my client, running on Windows 2000 SP4.

When given the URL:

  http://eric:eva1hz2i@pubtest.vss/Temp/pfiboot.exec;type=a

Here's the output from wU-FTD's command log:

  Oct 27 10:47:32 pubtest ftpd[1391]: USER eric
  Oct 27 10:47:32 pubtest ftpd[1391]: PASS password
  Oct 27 10:47:32 pubtest ftpd[1391]: FTP LOGIN FROM eric.vss [192.168.64.41], eric
  Oct 27 10:47:32 pubtest ftpd[1391]: SYST
  Oct 27 10:47:32 pubtest ftpd[1391]: PWD
  Oct 27 10:47:32 pubtest ftpd[1391]: TYPE Image
  Oct 27 10:47:32 pubtest ftpd[1391]: PASV
  Oct 27 10:47:32 pubtest ftpd[1391]: SIZE /home/eric/Temp/pfiboot.exec
  Oct 27 10:47:32 pubtest ftpd[1391]: MDTM /home/eric/Temp/pfiboot.exec
  Oct 27 10:47:32 pubtest ftpd[1391]: RETR /home/eric/Temp/pfiboot.exec

Mozilla sure seems to be forcing an Image (binary) transfer, despite the
"type=a" component in the URL.

After the file has been sent by the FTP server, it is displayed in the browser
window. Performing a File | Save As function creates a file with LF delimiters,
instead of the CRLF that would be expected for a Windows text file.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

12 years ago
still broken!

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.5b1/win32/xpi/reporter.xpi;type=a
will try to install an extension, not display the file on screen.

Obviously nobody can be bothered to even glance at bugs they're assigned, so
I'll just mark it WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.