Floats are overlapped when background-attachment: fixed is being used on other elements

RESOLVED DUPLICATE of bug 191830

Status

()

P2
normal
RESOLVED DUPLICATE of bug 191830
16 years ago
4 months ago

People

(Reporter: u103550, Assigned: roc)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Opera/7.11 (Windows NT 5.1; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Elements with background-attachment: fixed are treated as topmost elements thus 
overlapping other elements that float. Absolute positioning works as expected.

Reproducible: Always

Steps to Reproduce:
1. Load URL :)
Actual Results:  
I cannot read the contents of the page due to the fixed background that elevates 
the element above others

Expected Results:  
Gecko should have rendered the element with the fixed background the same way it 
renders the element with background-attachment: scroll. Problem: Content hidden 
or overlapped. That might lead to a loss of information
Looks legit. ->roc
Assignee: float → roc+moz
Status: UNCONFIRMED → NEW
Component: Layout: Floats → Layout: View Rendering
Ever confirmed: true
Priority: -- → P2

*** This bug has been marked as a duplicate of 191830 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.