Form elements should be emptied upon reload

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 46845
14 years ago
13 years ago

People

(Reporter: Timwi, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Currently, form elements are re-filled with the data I entered when I reload
the page. This should not be the case (or at least there should be some way for
me to reset the form even without there having to be a "reset" button on the
webpage).

Imagine, for example, I made inadvertant changes in the fields of a BugZilla
bug, or an article on Wikipedia, or something. I want to be able to just reload
the page and get the server-supplied form field contents.

Reloading of a page should do the same as following a link to the same page.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
This is currently by design.  To reload the page and reset the fields, do a
shift-reload.

Whether or not that behavior should be changed is the subject of bug 46845.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.