Closed Bug 211928 Opened 17 years ago Closed 17 years ago

DIR=RTL not correctly handled for UL items

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 74880

People

(Reporter: jimkeir, Assigned: mkaply)

Details

(Keywords: rtl, testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4) Gecko/20030624

Setting "DIR=RTL" on a UL results in correct formatting but no indent, hence the
bullet point is not visible without explicitly specifying a text indent.

Reproducible: Always

Steps to Reproduce:
HTML Example:
<HTML>
<BODY>
<H2>RTL Test Case </h2>
<UL DIR="RTL">
<LI>Item One
<LI>Item Two
</UL>
<DIV STYLE="text-indent: 2em">
<UL DIR="RTL">
<LI>Item One
<LI>Item Two
</UL>
</DIV>
</BODY>
</HTML>

Actual Results:  
No indent on first UL group

Expected Results:  
Automatic indent on first UL group, as for LTR.
This could probably benefit from an implemenation of margin-start....
Attached file Testcase #2
Confirming bug, 2003-07-03-22 trunk Linux.  Here's a preliminary list of UA
rules that are not "RTL safe":

From html.css:
 dd {
   display: block;
   margin-left: 40px;
 }

 blockquote[type=cite] {
   display: block;
   margin: 1em 0px;
   padding-left: 1em;
   border-left: solid;
   border-color: blue;
   border-width: thin;
 }

 ul, menu, dir {
   display: block;
   list-style-type: disc;
   margin: 1em 0;
   padding-left: 40px;
   -moz-counter-reset: -html-counter 0;
 }

 ol {
   display: block;
   list-style-type: decimal;
   margin: 1em 0;
   padding-left: 40px;
   -moz-counter-reset: -html-counter 0;
 }


From quirks.css:
 dl > dl {
   display: block;
   margin-left: 40px;
 }

:not(dl) > dd:before {
  display: inline;
  white-space: pre;
  font-size: 1px;
  line-height: 0;
  content: "\A  ";
  margin-right: 40px;
}


From what I can see, we need padding/margin/border-start/end to implement
the above so it works for RTL.
Shouldn't bugs like this go to Layout/Style System?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows NT → All
Hardware: PC → All

*** This bug has been marked as a duplicate of 74880 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.