Closed Bug 211951 Opened 17 years ago Closed 17 years ago

Mozilla Firebird should detect infinite JavaScript loops, and prevent them from running

Categories

(Firefox :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 13350

People

(Reporter: xslf, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030619 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030619 Mozilla Firebird/0.6

The above site has some templates to use in web site, which contain a bug- when
opened in a tab in the background, they fall into a JavaScript infinit loop,
giving infinite JavaScript pop-ups.

The only way to get out, is to kill mfb- loosing all the other open tabs.

mfb should be smart enugh to detect such a loop, and prevent it from running
infinite.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.registryofdesign.com/archives/000514.php
2. Open the "I Believe" link in a background tab
3. see the pop-ups, and try to get out of the loop

Actual Results:  
infinite loop- only way to get out is by killing the browser

Expected Results:  
browser should not fall into such bad code bugs.

*** This bug has been marked as a duplicate of 13350 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Mass-verifying. Sorry for bugspam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.