bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

No documention on how to install Bugzilla as a non-root user

RESOLVED DUPLICATE of bug 207039

Status

()

Bugzilla
Documentation
RESOLVED DUPLICATE of bug 207039
15 years ago
6 years ago

People

(Reporter: SineSwiper, Assigned: Jacob Steenhagen)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030613
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030613

There's really no good documentation on The Bugzilla Guide - 2.16.3 Release
(Chapter 4) for installing Bugzilla (and Perl modules) as a non-root user.  I'd
like to add a section on the guide about this subject myself, if that's alright
with you guys/gals.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

15 years ago
A contribution in DocBook XML format would be great as I probably won't get
around to this one myself.

*** This bug has been marked as a duplicate of 207039 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
(Strange...I didn't get a e-mail on your comment.)

DocBook XML?  Well, that explains why the source code of the file is extremely 
bizzare.  Not quite sure how to write one of these.  I found some information 
on it here: http://www.docbook.org/xml/4.2/index.html.  But, it's just a DTD 
file on the specs.  Know of any good editors for it?

(Reporter)

Comment 3

15 years ago
Better yet, do you have the XML for the 4.1 page?  I can look at that and 
figure out how to write a 4.5 page "Linux (non-root) Installation Notes".
(Assignee)

Comment 4

15 years ago
All the source code is available in the docs/xml directory. The OS Notes section
is in installation.xml (along with the rest of the installation chapter). Being
that DocBook is just an XML doctype (we also use the style sheet from
http://tldp.org) any text editor will work. I myself use vim, but others (such
as the original doc author) use emacs.
(Reporter)

Comment 5

15 years ago
Thanks.  I figured it out.  Posting patch in proper bug...
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.