tab location / highlight location reset when step back in history

VERIFIED DUPLICATE of bug 36539

Status

()

enhancement
VERIFIED DUPLICATE of bug 36539
16 years ago
6 years ago

People

(Reporter: kevan, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030411 Phoenix/0.5+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030411 Phoenix/0.5+

Many other browsers (but not Firebird) maintain the "highlighted", or active
link when navigating from page to page - this is a very useful capability and
especially relevant when navigating via keyboard (tab, shift-tab, enter,
alt-left arrow/right arrow, etc.).

Hypothetical example: the user is on a page of links, and using the keyboard to
navigate. The user tabs through to the 3rd link (3 tabs), and follows it with
the enter key. The user reads the web page, and then wishes to navigate back to
the previous page, which can be accomplished with alt-left arrow. At this point,
the  "highlight location" is not the link that the user had just selected, but
the "root highlight location" - therefore to follow the next link in order
requires 4 tabs and the enter key.  If the browser behavior is changed so the
highlight is the link that was just followed, then the user can proceed to the
next link with just a single tab, and then enter. This is highly useful when
trying to quickly navigate through a series of links via keyboard.

Reproducible: Always

Steps to Reproduce:
1. tab to Xth link on page, follow link
2. go back to parent page
3. tab to X+1th link on page

Actual Results:  
step 3 required X+1 tabs

Expected Results:  
Step 3 should have required 1 tab
Reporter

Comment 1

16 years ago
I know nothing about the programming behind Firebird, but I assume this would
require storing the "highlight location/page location" for each item in the
browser's history. Therefore you could move the user to the previous spot on the
page/previous link highlighted if they went back to that page.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified DUPLICATE 2003-ß9-03
Status: RESOLVED → VERIFIED

Updated

6 years ago
Depends on: 908597
No longer depends on: 908597
You need to log in before you can comment on or make changes to this bug.