Saving to disk should save directly to target if temp directory has insufficient space

VERIFIED DUPLICATE of bug 69938

Status

VERIFIED DUPLICATE of bug 69938
16 years ago
14 years ago

People

(Reporter: binarydreams, Assigned: darin.moz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When using the save to disk function, the file is saved to the temporary folder
first, then moved to the target destination.  When downloading a very large file
which is larger than the free space on the partition which holds the temporary
folder, the file should be saved directly to the target destination.

Reproducible: Always

Steps to Reproduce:
1. Attempt to download a file larger than the free space on your temporary
folder's drive to a drive where there is sufficient space.

Actual Results:  
The download will consume all the disk space on the temporary folder's drive,
then fail.

Expected Results:  
The browser should have detected that there was insufficient space and opted to
save the file directly to the target instead of the temporary directory.

*** This bug has been marked as a duplicate of 69938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Which command are we talking about?

I'm going to assume you meant "save target link as...", because that would cause
a network event and probably trigger download manager.

"Save page as", should read out of cache, and presumably not write to local temp
space.
Component: Networking: File → Download Manager
QA Contact: benc → petersen
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.