Should be a preference to enable/disable saving to temporary space.

VERIFIED DUPLICATE of bug 69938

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 69938
15 years ago
2 years ago

People

(Reporter: Jeff Myers, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When using the Save file to disk function, files are saved to the temporary
directory, then moved to the target destination.  In some cases this is not the
desired behavior (for instance when saving very large files).  The user may
prefer to save the files directly to the target location.  Currently you can get
around this by using the Save Link Target As... option from the context menu,
which has an inconsistancy (see bug 212167) which causes the file to be saved
directly to the target.  There should be an option in the advanced preferences
to choose which downloading behavior the user would prefer.

Reproducible: Always

Steps to Reproduce:
1. Use the standard save file to disk function by clicking on a link of a file
type which defaults to being saved (exe, zip, gz)

Actual Results:  
The file is always saved to the temporary space, then moved to the target
destination.

Expected Results:  
There should be a preference option to allow the file to be saved directly to
the target destination without using the temporary space.

*** This bug has been marked as a duplicate of 69938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Component: Networking: File → File Handling
QA Contact: benc → petersen
verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.