Mozilla unusable if mail server chamges IP address

RESOLVED DUPLICATE of bug 162871

Status

defect
--
major
RESOLVED DUPLICATE of bug 162871
16 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: sspitzer)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612

If the named mailserver changes its IP address, mozilla does not try to resolve
it again which would work but uses a cached version of the DNS lookup which
causes it to constantly return errors until you kill the mozilla process. This
is an issue for people who run their own mailserver off a dynamic dns account
but keep the same hostname through dyndns (or other service) and their lease
renews with a different IP address (I was using IMAP).

Reproducible: Always

Steps to Reproduce:
1. open mail, access account
2. have mailserver change ip addresses
3. try to access mail again

Actual Results:  
mozilla return "not found" errors regarding the mailserver

Expected Results:  
instead of relying on a cached version of the DNS it should have done a fresh
lookup which would have resolved successfully

Comment 1

16 years ago
does mozilla actually "crash" ?
Summary: crash if mail server chamges IP address → crash if mail server chamges IP address

Updated

16 years ago
Severity: major → critical
Keywords: crash

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 162871 ***
Severity: critical → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: crashhang
Resolution: --- → DUPLICATE
Summary: crash if mail server chamges IP address → Mozilla unusable if mail server chamges IP address

Comment 3

16 years ago
VERIFIED/dupe.
QA Contact: gchan → benc
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.