Feature Request: Launch webDAV aware helper apps with URL instead of /tmp file.

RESOLVED DUPLICATE of bug 90501

Status

Core Graveyard
File Handling
--
enhancement
RESOLVED DUPLICATE of bug 90501
15 years ago
a year ago

People

(Reporter: Brandon Hines, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Poor interoperability [user experience] when handing off webDAV content to
webDAV aware applications.

When selecting a document on a web page Mozilla downloads the file to /tmp and
loads the /tmp/file.sxw file into OpenOffice.org.  Then the helper app only
knows about the /tmp file and not the webDAV resource.

It would be better if Mozilla could be configured to simply launch the helper
app with the URL instead of the tmp file.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Currently, when selecting a document on a web page, an .SXW file for example,
Mozilla downloads the file to /tmp and loads the /tmp/file.sxw file into
OpenOffice.org.   Although OpenOffice.org is webDAV aware, the file cannot be
edited and easily saved back to the webDAV server without manually re-specifing
the URL.

Expected Results:  
It would be better if Mozilla could be configured to simply launch the helper
app with the URL instead of the tmp file.  This would hand off the
responsibility for downloading the resource to the webDAV aware helper app
enabling the user to easily edit the file and save changed directly back to the
webDAV server.
(Reporter)

Updated

15 years ago
OS: Linux → All

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 90501 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.